49

My mouse pointer became invisible after some updates after I upgraded to 15.04 from 14.10. In all standard settings the mouse pointer is activated (system settings, dconf...) I also tried different cursor icons with no success.

The pointer is sometimes visible after I shut down and reboot the system. But only sometimes and I couldn't figure out a patterns why it sometimes shows up.

I found the following solution which did not work

gsettings set org.gnome.settings-daemon.plugins.cursor active false

Any help appreciated! thanks!

  • Happened the same to me upgrading to 14.04. I think it's a bug/interaction for having had both gnome and unity installed. Apart from the command you mention, I had to switch from lightDM to GDM. – Rmano Aug 1 '15 at 11:37
  • Did you post a bug report? – blade19899 Sep 28 '15 at 17:50
  • As of 2017-03-22 this problem has been solved by an update. – Ulad Kasach Mar 22 '17 at 18:38

26 Answers 26

45

This bug is still around for a Xubuntu 16.04 system using lightdm. A fix for Xubuntu, and possibly other DE's, as described on the Xubuntu 16.04 Release Post is to bring the cursor back with Ctrl+Alt+F1 followed by Ctrl+Alt+F7 .

This worked for me, where none of the other solutions had without reloading everything and closing every page.

  • 5
    As of 2016-06-04 this seems to be the best solution in that 1) it actually works (unlike the gsettings or modprobe suggestions) and 2) doesn't involve killing all of your open applications by restarting lightdm. – M. Berk Jun 4 '16 at 8:39
  • 3
    Note to the less Linux-experienced such as myself: Ctl+Alt+F1 will (somewhat frighteningly) drop you into a full-screen virtual terminal session. Ctrl+Alt+F7 will drop you back into your previous desktop session with all of your windows intact. – trvrfrd Jul 21 '16 at 14:40
  • 1
    Didn't solve the issue. Using Ubuntu 16.04.1 LTS. dopsar's answer below worked though. – Dzhuneyt Jan 2 '17 at 19:26
  • Works on Ubuntu 17.10 as well. – phobic Feb 22 '18 at 11:21
30

I have the same problem after upgrading to 15.04 from 14.10. Sometimes the mouse pointer will appear, this happens approx 1 in 5 computer switch on times. I found a way to get round this as suggested above.

(note: this will hard-kill any running processes).

sudo service lightdm restart

This does have to be issued after every start up . Does anybody know of a more long-term fix?

I have now found a long-term fix. Switch to gdm instead.

sudo apt-get install gdm

after trying several reboots this fix seems to work every time.

I don't know if lightdm gives any advantages over gdm, but to me seeing the cursor is a big advantage of GDM over lightdm.

  • After over 2 month of trying I also switched to gdm... thanks for pointing that out! – weelux Aug 2 '15 at 13:59
  • 3
    Mind explaining what restarting lightdm does? Does it really "blank out" your screen (it did to me)? (I was hoping I could get my mouse pointer back without restarting because there's a lot I'm working on. So I tried this out and it blanked out my screen. Ended up doing a manual restart. Is that really supposed to happen?) – skytreader Oct 13 '15 at 15:15
  • 21
    Hey! RE: sudo service lightdm restart, that just hard-killed every app and a virtual machine I was running. You might want to add a little warning about that to your answer. – ahcox Nov 6 '15 at 19:57
  • 2
    I switched to gdm, and the computer didn't start at all! – Nick Mar 31 '16 at 8:03
  • 1
    On lubuntu this killed all applications running... this is not a good answer – ForeverConfused Aug 15 '16 at 22:20
13

A dirty hack I do (which surprisingly works for me) is to open terminal by pressing Ctrl+Alt+T and then type ls then the mouse shows in 1-2 seconds.

That said, the normal way that works is to restart the mouse driver. This solution also works when the mouse pointer is misbehaving (like flickering randomly out of control). You restart the mouse driver like:

sudo modprobe -r psmouse  # disable the driver
sudo modprobe psmouse # enable the mouse driver
  • 1
    Odd shortcut, but if it works... – Daniel Nov 14 '15 at 17:20
  • 4
    ls in terminal works fine in Xubuntu 16.04 Beta 2. Of course restating lightdm works as well. – Kev Inski Apr 9 '16 at 17:33
  • Nothing about ls as far as I can tell. Just opening a terminal and pressing return brings the cursor back. Maybe the terminal is also a red herring... – andybuckley May 5 '16 at 10:00
  • 1
    works on 14.04. – sjt003 Aug 7 '17 at 18:41
7

I have similar problem. Mouse pointer is invisible after system boot, even on LightDM screen. To bring cursor back I'm switching to virtual console (ctrl+alt+f1) and run command:

sudo service lightdm restart

After LightDM restart mouse pointer back to normal. I reported this bug to Launchpad.

5

Open a terminal ctrl+alt+t and type sudo apt-get install lightdm --reinstall then sudo shutdown -r now to reboot. This worked for me and I've tested it by rebooting several times.

  • This one did it for me as well on 15.04 – Einar Sundgren Oct 14 '15 at 19:39
  • It worked for me also – Hatem Jaber Nov 5 '15 at 20:48
  • Did not work for me on 14.04 – Planky Dec 17 '15 at 17:02
  • Clearly the most reasonable answer. Everything else is merely a temporary or hacky workaround. – Michael Aug 8 '16 at 5:49
  • This worked for me. 4.4.0-79-generic Ubuntu 16.04 LTS – Rick2047 Jun 15 '17 at 7:48
3

There can be some problems of this kind if you have got nvidia optimus technology in your computer. Try to use different driver (e.g. Noveau display driver) from Additional Drivers tab in Software & Updates.

  • Thanks! But I'm not using nvidia optimus though. I only have an integrated graphics card – weelux May 21 '15 at 14:53
  • 1
    If you go to tty1 (ctrl+alt+f1) and then back to gui (ctrl+alt+f7), does you cursor appear correctly? – apex39 May 21 '15 at 16:37
  • No, unfortunately not :( – weelux May 24 '15 at 12:22
  • 1
    I have a GK107GLM (Quadro K1100M). I experienced this issue and solved it by opening the Additional Drivers panel and just clicking on another driver (one of the NVIDIA proprietary ones). Just clicking on another driver resolved the problem. I didn't even have to apply the changes. – henko Aug 17 '15 at 12:03
  • Strange, do you have another driver highlighted now? – apex39 Aug 17 '15 at 13:02
3

I fixed it by going to displays setting (write dis in search bar) and than turned off the "unknown display". U see in displays setting two displays in the middle of picture in settings. One is built-in-display another is unknown. Choose unknown by clicking on it on the picture and take the button next to the "Unknown Display" from on to off. Tada

2

From this post on Ubuntu forums, running this command in a terminal fixed this issue

gsettings set org.gnome.settings-daemon.plugins.cursor active false

This works intermittently for me... and I don't know yet why it works at times and not others, but. may help you too.

  • 1
    In my post you can see that I already tried this method and it doesn't work for me – weelux Aug 2 '15 at 13:55
  • Confirmed to work with Synergy 1.8.7-stable-9799e96 on Ubuntu 16.04 while sharing a mouse from macOS 10.12.2. – Pétur Ingi Egilsson Jan 21 '17 at 19:48
2

Issuing the following command will restart compiz (the window manager and decorator), without loosing your desktop and loging out (like restarting lightdm would):

sudo killall -i -HUP compiz

That brought my cursor back when it disappeared, while keeping all my windows and my currently working programs.

  • Thank you, this was the ONLY command that worked when all other didn't work (other than restart lightdm which I dont want to do) – AnthonyC Sep 28 '17 at 22:58
1

I had this problem as well, it seems like replacing gnome-setings-daemon with unity-settings-daemon seems to fix this problem.

  • I removed gnome-settings-deamon and unity-settings-deamon was already installed but no change occured. Is that what you meant? Thanks! – weelux May 21 '15 at 15:03
1

Have you tried this:

 gsettings set org.settings.daemon-plugins.cursor -KEY=s.cursor -VALUE=false

and it might work fine this way.

  • I get: No such schema 'org.settings.daemon-plugins.cursor' – weelux Aug 4 '15 at 14:21
1

This is a very old Unity bug to which that are references that date back to 13.04. Given that Unity version 7 is reaching its end of life, probably it will never be fixed. For a while, logging out and logging back in would temporarily revive the mouse pointer, but this workaround no longer does it on Ubuntu 14.04. The gsettings set command is not functional on 14.04 either.

However, this problem can be fixed on 14.04 by issuing this command:

setsid unity

This will reset all your Unity options, number of workspaces, launcher size, etc. But better that than not having the mouse pointer.

1

Ubuntu 16.04 and Gnome Flashback here. The mouse cursor would disappear during login. Similar fix as mentioned above. I used "dconf Editor" and searched for "cursor". I found the value that fixed the issue in the location:

org,gnome,desktop,settings-daemon,plugins,cursor,active

I unticked active and my mouse come back instantly and is surviving restarts.

0

I fixed this issue by deleting my .config folder from my home dir (~) after noticing the issue only appeared on one user. While not ideal it is a possible fix.

0

Doing this solved the problem for some of the users: install dconf-editor

sudo apt-get install dconf-editor

and change the icon size to smaller in settings. That seems to solve the issues

0

Here is how I solved the problem:

Create a shell script (yourscript.sh) with this code:

#!/bin/bash
service lightdm restart 

As root, move it to the /etc/init.d folder Then, open the folder in the terminal and run:

chmod 755 yourscript.sh 

Then, while in terminal, enter this command:

ln -s /etc/init.d/yourscript.sh /etc/rc2.d/S99yourscript.sh 

Now, your mouse pointer will appear at every boot and the problem of the invisible mouse pointer should be gone.

References:

https://askubuntu.com/a/290107

https://askubuntu.com/a/629965/462410

0

I had the same issue after upgrading to 16.04. I tried to install gdm as suggested by @user417467 but this didn't solve the problem so I reverted back to lightdm. I found that after logging back I can make the pointer reappear simply by pressing crtl+F7.

0

Setup: Ubuntu 14.04 with default installation. I have automatic login enabled as well.

For me, I simply log off and log in again. At the login screen the mouse cursor returns and remains till next restart. Works every time for over 50 times now.

0

I solved it by plugging an unused wireless mouse dongle in to keep the driver happy.

  • I always have a wireless mouse plugged in and it still happens. – Gabriel Staples Jun 5 '16 at 23:42
  • This is the first answer on this page that worked for me. – Doug Bradshaw Aug 5 '16 at 3:33
0

Well, On Ubuntustudio 16.04, I found out that if I get the mouse to hover the button for the app menu, and start to browse, it comes right back no problem!!

0

I had the same issue on XUbuntu 15.10.

The only working way I found to get back the cursor is:

  1. Ctrl+Shift+T (open the terminal)
  2. sudo apt-get install gnome-screensaver
  3. Ctrl+Shift+L (lock screen)
  4. got the cursor back...
0

I had a similar problem on 15.04. At one point the mouse cursor suddenly disappeared, but when I moved to another workspace (Ctrl+Alt+Arrow) it reappeared.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. – David Foerster Aug 17 '15 at 10:06
  • @DavidFoerster It is an answer. My point is that switching to a different workspace might solve the issue, at least for some users; it worked for me. – Pulsar Aug 17 '15 at 17:41
  • 1
    but this is not a proper solution, but a work around! – Edward Torvalds Aug 17 '15 at 20:55
  • Didn't work for me on Ubuntu 14.04 – Planky Dec 17 '15 at 17:03
0

I came here from google because I have been experiencing the same problem in ubuntu 16.04 . The last several times it has happened, i was reliably able to get the mouse back by simply opening a terminal using ctrl + alt + t .

better than having to reboot every time.

0

Same problem upgrading Lubuntu 14.04 to Lubuntu 16.04. Cursor disappear after resume. Ctr-Alt-F1 , Ctr-Alt-F7 solve the issue.

0

The top few answers did not work for me, however I managed to solve my problem by unplugging and re-plugging my USB mouse.

-1

I had to create a file called:

20-intel.conf // I'm using intel graphics

place the file on:

/etc/X11/xorg.conf.d/

Using these lines:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        Option      "AccelMethod" "uxa"
        Option      "SWCursor" "on"
        BusID       "PCI:0:2:0"
EndSection

protected by Community Dec 4 '16 at 22:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.