I'm on 11.10, and no wireless networks I create are staying connected. I had created one called "cookie" many moons ago, then deleted it some time after upgrading to 11.10.

Strangely, that network showed up today, after applying some updates, yet the system still will not remain connected to any ad-hoc networks I create. I reported a bug (as one should do) but it has been ignored for a long time now, and it is allegedly fixed, but I still have the problem.

See this output: http://pastebin.com/LAEB9H1u

What can I do to get normal functionality back? Is there some way to clean network manager's configuration so I can start with a clean slate without reinstalling the entire system?


Have you tried reinstalling NetworkManager? If you can connect via ethernet — because, naturally, removing NetworkManager would disconnect you — try:

sudo apt-get -y purge network-manager

sudo apt-get -y install network-manager

I have had problems with NetworkManager in the past, and therefore use wicd most of the time. However, it does not have certain features, like managing multiple interfaces at a time, and creating ad-hoc networks, etc., so I use NetworkManager when I have to, but otherwise, I use wicd.

Edit: If this does not work, please try the CLI method as described here: https://help.ubuntu.com/community/WifiDocs/Adhoc

  • Thanks for the answer, I will try to reinstall network-manager itself soon. Have you had this problem before? – RolandiXor Oct 8 '11 at 20:31
  • I have not had this problem, in fact, AdHoc usually works pretty good for me. I actually got quite annoyed when it connected to my AdHoc network every single time I turned on my laptop, so I disabled the Automatic connecting of the network. Anyway, I assume you have already tried creating a new adhoc network? – Matt Oct 8 '11 at 20:34
  • a million times :D – RolandiXor Oct 8 '11 at 20:34
  • Lol, okay.. Most of my issues with it was not being able to connect to WPA/WPA2. And sometimes the applet would not show up. Whenever the daemon is running, it will screw wicd up so it cannot connect. I have two scripts, one to disable NetworkManager, including changing the binary daemon to non-executable, and one to make it executable and run it. Please read the edit^^ – Matt Oct 8 '11 at 20:39
  • I tried the purging and reinstalling method - no use :/ – RolandiXor Oct 8 '11 at 21:05

After a not so merry go round of purging network manager and reinstalling restarting, logging in and out about twice, deleting all networks, and trying again...

The maintainer told me it was ipv6. I set it to ignore and the network sticks :D!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.