My fonts, windows are often affected by graphic distorisions, bugs, sometimes disapear without any reasons.

When I reboot it is generally solved.

This is happening since I update my kernel and graphics, but I don't know how to solve it.

I have a Dell XPS 13 running ubuntu 14.04, with Intel HD5500.

Output of lspci -k | grep VGA -A2

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
Subsystem: Dell Device 0665
Kernel driver in use: i915

Output of dpkg -l | grep xserver-xorg-core

rc  xserver-xorg-core                                     2:1.15.1-0ubuntu2.7                                 amd64        Xorg X server - core server
ii  xserver-xorg-core-lts-utopic                          2:1.16.0-1ubuntu1.2~trusty2                         amd64        Xorg X server - core server

enter image description here

enter image description here

  • Please edit your question and add there output of "lspci -k | grep VGA -A2" terminal command.
    – Pilot6
    May 20, 2015 at 8:22
  • And also "dpkg -l | grep xserver-xorg-core"
    – Pilot6
    May 20, 2015 at 8:27
  • It looks like a bug in the newer intel driver.
    – Pilot6
    May 20, 2015 at 8:34
  • So I can't do anything about it ? May 20, 2015 at 8:35
  • You can revert xorg to the previous version
    – Pilot6
    May 20, 2015 at 8:36

2 Answers 2


This looks like a bug in Intel graphics drivers. There is no vivid HWE for trusty yet. So you can do one of these:

  1. Wait till new HWE appears in Ubuntu repositories. It is a matter of a week or two, then upgrade to it. I prefer this.
  2. Install Ubuntu 15.04.
  3. Do 2 + Intel graphics installer. (I do not like this)

This solution seems to have partially fixed it for me UBUNTU 14.04 Gui text and pictures displaying problem like a virus

But instead of the following :

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "AccelMethod"  "uxa"

I have set the AccelMethod to sna

Indeed, UXA was giving me terrible lag

  • This is not a real solution, but a workaround. But workable.
    – Pilot6
    May 20, 2015 at 9:06
  • Yes that's what I tought, but still it seems to be working pretty well, less buggy, and graphics are also working faster so I will stick with it until Intel releases a knew driver, as you adviced May 20, 2015 at 9:08
  • For more information on what this actually does, see man 4 intel or wiki.archlinux.org/index.php/Intel_graphics#Troubleshooting. I have seen similar problems with 15.04 on a new laptop with Broadwell Intel Integrated graphics, but as far as I can tell sna mode is used by default - verified through grep -i uxa /var/log/Xorg.0.log from the comments here: cynic.cc/blog/posts/sna_acceleration_vs_uxa
    – Yi Jiang
    Sep 8, 2015 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.