5

I have been trying to install PCL for linux on Ubuntu 14.10: http://pointclouds.org/downloads/linux.html

So far, I have done the first two steps,

sudo add-apt-repository ppa:v-launchpad-jochen-sprickerhof-de/pcl
sudo apt-get update

But it fails on the third:

$ sudo apt-get install libpcl-all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libpcl-all

What can I do to solve this problem? I have looked online, but all the existing threads do not seem to have a working resolution.

2 Answers 2

7

Install libpcl1, it's in the Ubuntu repositories:

sudo apt-get install libpcl1

Or as @Fabby said, compile your own version:

sudo apt-get install git
cd
git clone [email protected]:PointCloudLibrary/pcl.git
cd pcl
mkdir build
cd build
cmake ..

Note the missing development libraries, eg:

-- checking for module 'eigen3'
--   package 'eigen3' not found
-- checking for module 'flann>=1.7.0'
--   package 'flann>=1.7.0' not found

and install the development libraries with, eg:

sudo apt-get install libeigen3-dev
sudo apt-get install libflann-dev

Start the compiler with make

make

And install

  • the classic way make install

    sudo make install
    
  • with checkinstall

    sudo apt-get install checkinstall
    sudo checkinstall
    
1
  • 2
    libpcl1 is Portable Coroutine Library, not Point Cloud Library.
    – KalEl
    Commented Apr 5, 2019 at 4:15
0

Because for your version of Ubuntu this library does not exist in this PPA.

To solve this, you need to build from source instead.

2
  • As you're a reputation 1 user: If this answer helped you, don't forget to click the grey at the left of this text, which means "yes, this answer is valid"! ;-)
    – Fabby
    Commented May 20, 2015 at 1:47
  • 1
    He, this is a link only answer =P =)
    – A.B.
    Commented Sep 20, 2015 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .