4

What is the proper way to configure arm command in tor-arm package to work on 14.04? Because every time I run arm it returns:

Connection refused. Is the ControlPort enabled? 

I didn't happen to come across on some good solution while googling, I found this tutorial but still no luck, I guess I'm missing a point somewhere.

  • have you enabled all the necessary ports? – Ron May 27 '15 at 7:22
  • I dunno what is exactly the port that it requires I use tor with Firefox on port 9050 when I run it: arm -i 127.0.0.1:9050 Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/TorCtl/TorCtl.py", line 710, in _loop isEvent, reply = self._read_reply() File "/usr/lib/pymodules/python2.7/TorCtl/TorCtl.py", line 885, in _read_reply raise ProtocolError("Badly formatted reply line: unknown type %r"%tp) ProtocolError: Badly formatted reply line: unknown type 'P' Terminated – JoKeR May 27 '15 at 10:13
  • when I run arm -i 127.0.0.1:9051 it says connection refused as stated in OP – JoKeR May 27 '15 at 10:14
  • In my case the torrc was overwritten and while I added the correct values Tor would not reconnect. I had to restart the tor service also. – Avec Mar 22 '18 at 10:28
2

First you have to configure TOR For this : We can find the configuration file at /etc/tor/torrc. It’s owned by root, so we’ll have to sudo to edit it:

$ sudo nano /etc/tor/torrc

We’ll uncomment the options we need, and set them to the appropriate values, ending up with something like this:

ORPort 9001
DirPort 9030
ExitPolicy reject *:*
Nickname trustytohr
RelayBandwidthRate 1 MB
RelayBandwidthBurst 2 MB
AccountingStart month 1 00:00
AccountingMax 100 GB
DisableDebuggerAttachment 0**

The most important settings are probably ORPort, DirPort and ExitPolicy

after this restart TOR and run arm

0

The question is kind of old, but I found myself trying to fix the same issue and what I had to was generate a hashed password with tor --hash-password password and uncomment and substitute the HashedPassword line found at /etc/tor/torrc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.