1

I can't run tor from Iran with obfs3 but when I download the latest version of Tor Browser from https://www.torproject.org/dist/torbrowser/4.5.1/tor-browser-linux64-4.5.1_en-US.tar.xz, it worked correctly. Probably because the last version of tor from https://launchpad.net/ubuntu/+source/tor ppa is 0.2.5.12-1 but the latest version of tor from https://blog.torproject.org/category/tags/tbb is 0.2.7.5.

I don't like to use Tor Browser, so how can I install the latest version of tor package?

So, I try option two from https://www.torproject.org/docs/debian.html.en#ubuntu

$ cat /etc/apt/sources.list
deb http://archive.canonical.com/ trusty partner
deb-src http://archive.canonical.com/ trusty partner
deb http://us.archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main universe restricted multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main universe restricted multiverse
deb http://deb.torproject.org/torproject.org trusty main
deb-src http://deb.torproject.org/torproject.org trusty main

and

$ gpg --keyserver keys.gnupg.net --recv 886DDD89
gpg: requesting key 886DDD89 from hkp server keys.gnupg.net
gpg: key 886DDD89: "deb.torproject.org archive signing key" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

and

$ gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -
    OK

then

$ sudo proxychains  apt-get update 

and

$ sudo proxychains apt-get install tor deb.torproject.org-keyring
ProxyChains-3.1 (http://proxychains.sf.net)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libseccomp2 tor-geoipdb torsocks
Suggested packages:
  mixmaster xul-ext-torbutton socat tor-arm polipo privoxy apparmor-utils
The following NEW packages will be installed:
  deb.torproject.org-keyring libseccomp2 tor tor-geoipdb torsocks
0 upgraded, 5 newly installed, 0 to remove and 10 not upgraded.
Need to get 1,490 kB of archives.
After this operation, 7,010 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
0% [Working]|DNS-request| us.archive.ubuntu.com 
|DNS-request| deb.torproject.org 
|S-chain|-<>-127.0.0.1:9150-<><>-4.2.2.2:53-|S-chain|-<>-127.0.0.1:9150-<><>-4.2.2.2:53-<><>-OK
<><>-OK
0% [Connecting to us.archive.ubuntu.com] [Connecting to deb.torproject.org]|DNS-response| us.archive.ubuntu.com is 91.189.91.14
|S-chain|-<>-127.0.0.1:9150-<><>-91.189.91.14:80-|DNS-response| deb.torproject.org is 82.195.75.101
0% [Connecting to us.archive.ubuntu.com (91.189.91.14)] [Connecting to deb.torp<><>-OK
<><>-OK
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty/main libseccomp2 amd64 2.1.0+dfsg-1 [34.8 kB]
Get:2 http://deb.torproject.org/torproject.org/ trusty/main deb.torproject.org-keyring all 2014.08.31+b1 [5,268 B]
Get:3 http://us.archive.ubuntu.com/ubuntu/ trusty/universe torsocks amd64 1.3-3 [73.0 kB]
Get:4 http://deb.torproject.org/torproject.org/ trusty/main tor amd64 0.2.5.12-1~trusty+1 [837 kB]
Get:5 http://deb.torproject.org/torproject.org/ trusty/main tor-geoipdb all 0.2.5.12-1~trusty+1 [540 kB]
Fetched 1,490 kB in 26s (56.7 kB/s)                                            
Selecting previously unselected package libseccomp2:amd64.
(Reading database ... 641228 files and directories currently installed.)
Preparing to unpack .../libseccomp2_2.1.0+dfsg-1_amd64.deb ...
Unpacking libseccomp2:amd64 (2.1.0+dfsg-1) ...
Selecting previously unselected package deb.torproject.org-keyring.
Preparing to unpack .../deb.torproject.org-keyring_2014.08.31+b1_all.deb ...
Unpacking deb.torproject.org-keyring (2014.08.31+b1) ...
Selecting previously unselected package tor.
Preparing to unpack .../tor_0.2.5.12-1~trusty+1_amd64.deb ...
Unpacking tor (0.2.5.12-1~trusty+1) ...
Selecting previously unselected package torsocks.
Preparing to unpack .../torsocks_1.3-3_amd64.deb ...
Unpacking torsocks (1.3-3) ...
Selecting previously unselected package tor-geoipdb.
Preparing to unpack .../tor-geoipdb_0.2.5.12-1~trusty+1_all.deb ...
Unpacking tor-geoipdb (0.2.5.12-1~trusty+1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Setting up libseccomp2:amd64 (2.1.0+dfsg-1) ...
Setting up deb.torproject.org-keyring (2014.08.31+b1) ...
OK
Setting up tor (0.2.5.12-1~trusty+1) ...
Something or somebody made /var/lib/tor disappear.
Creating one for you again.
Something or somebody made /var/log/tor disappear.
Creating one for you again.
Warning from profile system_tor (/etc/apparmor.d/system_tor) ptrace rules not enforced
Warning from profile system_tor (/etc/apparmor.d/system_tor) signal rules not enforced
Warning from /etc/apparmor.d/system_tor (/etc/apparmor.d/system_tor line 18): profile system_tor network rules not enforced
 * Starting tor daemon...                                                       May 19 19:16:12.263 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
May 19 19:16:12.263 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
May 19 19:16:12.263 [err] Reading config failed--see warnings above.
                                                                         [fail]
invoke-rc.d: initscript tor, action "start" failed.
Tor was unable to start due to configuration errors.
Please fix them and manually restart the tor daemon using
 ´service start tor´
Setting up torsocks (1.3-3) ...
Processing triggers for ureadahead (0.100.0-16) ...
Setting up tor-geoipdb (0.2.5.12-1~trusty+1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

But still have old version!

$ tor -v
May 19 19:16:22.994 [notice] Tor v0.2.5.12 (git-3731dd5c3071dcba) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.1f and Zlib 1.2.8.
May 19 19:16:22.994 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
May 19 19:16:22.994 [warn] Command-line option '-v' with no value. Failing.
May 19 19:16:22.994 [err] Reading config failed--see warnings above.

Could you please help me to install latest tor package version?

  • Did you try apt-get install tor , and configure it ? – Bilal May 19 '15 at 15:30
  • @Serphiroth Yes, I did it and comfigure same as Tor Browser but doesn't work. – Daniyal May 19 '15 at 15:31
2

There is no such thing as tor 0.2.7.5. What you read about is Tor Launcher 0.2.7.5 which I suspect is a different thing that tor itself.

You can have (in decreasing order of stability) the following build:

  • the latest stable which 0.2.5.12.1
  • the latest experimental build which is 0.2.6.7.1
  • the latest dev build 0.2.7.1-alpha-dev-20150518T200057Z-1

none of them will be 0.2.7.5

  • Thank you very much, so is there any way to install ` latest experimental build which is 0.2.6.7.1` ? – Daniyal May 19 '15 at 17:00
  • 1
    Use deb http://deb.torproject.org/torproject.org tor-experimental-0.2.6.x-trusty main deb-src http://deb.torproject.org/torproject.org tor-experimental-0.2.6.x-trusty main in your sources.lsit – solsTiCe May 19 '15 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.