0

I have asked a question related to this problem before here How to fix Update error: Wrong sources.list entry or malformed file?. But I was told to ask a new question after it was established that my sources.list doesn't have any errors.

The problem started after I installed google chrome on my system. Now every time I do an update I get errors. Here is an output of errors I get after doing an update -

Err http://downloads-distro.mongodb.org dist Release.gpg                       
Could not resolve 'downloads-distro.mongodb.org'
Fetched 2,992 kB in 60s (49.1 kB/s)              
Reading package lists... Error!
W: Failed to fetch  http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  Bad header line [IP: 74.125.130.91 80]

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/main/binary-amd64/Packages  404  Not Found [IP: 74.125.130.91 80]

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/main/binary-i386/Packages  404  Not Found [IP: 74.125.130.91 80]

W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/trusty/Release  Unable to find expected entry 'restricted/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg  Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::1b). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::1b 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/partner/i18n/Translation-en_IN  Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::1b). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::1b 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/partner/i18n/Translation-en  Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::1b). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::1b 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/partner/binary-amd64/Packages  Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::1b). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::1b 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/partner/binary-i386/Packages  Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::1b). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::1b 80]

W: Failed to fetch http://downloads-distro.mongodb.org/repo/ubuntu-upstart/dists/dist/Release.gpg  Could not resolve 'downloads-distro.mongodb.org'

W: Some index files failed to download. They have been ignored, or old ones used instead.
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

Will reinstalling google chrome solve this problem? I am completely lost now. Please help!

marked as duplicate by karel, Kaz Wolfe, Zanna, David Foerster, edwinksl Dec 29 '16 at 10:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Post the content of your /etc/apt/sources.list and the content of all files in /etc/apt/sources.list.d with the extension .list. Not .list.save or similar. – A.B. May 19 '15 at 12:24
  • @ruudx Was this just a temporary network issue? – steakunderscore Mar 15 '16 at 14:47
1

Ok I may have an answer for you why this is happening but a solution is not withing my reach.

Look at this.

Missing Partner Repo In.archive.ubuntu.com

Similarly

http://dl.google.com/linux/chrome/deb/dists/stable/

is also not reachable

Also

http://downloads-distro.mongodb.org/repo/ubuntu-upstart/dists/dist/

was not reachable when you posted the question. But if you do a sudo apt-get update you should not get an error for

http://downloads-distro.mongodb.org/repo/ubuntu-upstart/dists/dist/

This is available now.

So I recommend you to wait for some time till the issues with the Backend Are fixed. There is nothnig wrong with your system. Just the backend repos are broken at the moment.

Not the answer you're looking for? Browse other questions tagged or ask your own question.