2

I've only really used Debian and Debian variants before and then only on either a virtual box or raspberry Pi. I'm trying to install the server variant of Ubuntu onto a Samsung N150 plus netbook (1GB ram, 150GB HDD)

In the install for some reason it wouldn't install GRUB it just said fatal error so I installed LILO (version 24 I think) but after that the install completed successfully. As I have a another windows PC, I let it use the whole disk to install too. On the first boot up it gives the following error:

[ 2.913376] input: ETPS/2 Elantech Touchpad as devices/platform/i8042/serio1/input/input6
Gave up waiting for root device. Common problems:
-boot args (cat /proc/cmdline)
-check rootdelay= (did the system wait long enough?)
-check root= (did the system boot to the right device?)
-missing modules (cat /proc/modules; Is /dev)
ALERT! /dev/sdb1 does not exist. Dropping to a shell!
[ 33.370303] hidraw: raw HID events driver (C) Jiri Kosina
[ 33.383562] usbcore: registered new interface driver usbhid
[ 33.387133] usbhid: USB HID core driver


BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) [ 41.000170] random: nonblocking pool is initialised

After that there was a pause (maybe 30 mins) just as I finished typing out the above it added two more lines on below:

[ 1292.492081] perf samples too long (2501 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 1292.492081] INFO: NMI handler (perf_event_nmi_handler) too long to run: 3.302 msecs
(initramfs)

I've tried googling the problem but most of the time it doesn't seem to happen on first boot very often. Most of the solutions involve changing code on a 'live cd.' I installed from a pen drive and when I boot from that the option is to run the install again but I don't see anywhere to access the terminal.

Any help would be much apprechiated!

  • To access the terminal from the live USB, choose 'try Ubuntu' instead of 'install Ubuntu'. – Organic Marble May 18 '15 at 20:24
  • "As I have a another windows PC, I let it use the whole disk to install too. On the first boot up it gives the following error: " Can you elaborate on what do you mean by saying this? – Paulius Šukys May 19 '15 at 6:12
  • There is no option for try instead of install. It first asks language choice and then into the install. – abba2566 May 20 '15 at 21:12
  • @PauliusŠukys Previously I had windows 7 installed on the netbook but I have another desktop with windows on it so I didn't want to dual boot the netbook. In the Ubuntu install it asks where you want to install it and I selected the option to use the full disk rather than create a partition – abba2566 May 20 '15 at 21:18
  • As an update to this, I did manage to use the repair future to install GRUB but that just loads a black screen with the word grub in it. I tried entering the command 'boot' and it says 'you need to load the Kernel first' – abba2566 May 20 '15 at 21:21
0

Use a live USB and boot your system.

Make sure you can mount your main partition in which your Ubuntu is installed. Lets assume it is /dev/sda1

Unmount that partition (NECESSARY). Now run this command which will fix errors in partition:

sudo fsck -a /dev/sda1

Make sure you you can mount the partition. Restart your system. it should work now.

(I faced with this problem today, I did exactly same thing and problem solved)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.