2

I use some private internet video broadcasting and it comes sometimes with a delay. Also, projector that I use also adds a delay to the video. So, I'd like to delay sound a bit in order to put sound in sync with video. I can't change the original video, and it is being viewed via some kind of private video player (flash based I suppose).

So, if I could somehow make a system-wide delay for the sound, it would be really nice.

I know, that a lot of video players do support sound synchronization, but using video player is not an option.

I've tried using pulseaudio for this, but with no success. Currently I've tried using ladspa with pulseaudio, but it seems like it does not see the module-ladspa-sink:

$ find /usr -name '*ladspa-sink*'
/usr/lib/pulse-4.0/modules/module-ladspa-sink.so
$ pacmd list-modules | grep ladspa
$ pacmd load-module module-ladspa-sink 
Welcome to PulseAudio! Use "help" for usage information.
>>> Module load failed.
$ pulseaudio --version
pulseaudio 4.0
$ uname -a
Linux lenovo-g570 3.13.0-52-generic #85-Ubuntu SMP Wed Apr 29 16:44:17 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:        14.04
Codename:       trusty

Kubuntu, actually.

3
  • Do you have pavucontrol installed? On tab "Output devices" -> "Advanced" you can set a latency offset. – davidbaumann May 18 '15 at 19:25
  • Well, that works. But for some applications only. That is, it affects players (mpv) immediately. But flash in chrome does not seem to react. No matter what I write there that player just keeps playing with the same delay. Youtube video played in native video player is affected, but not flash one. – TiGR May 18 '15 at 20:27
  • And positive numbers of this latency gain just the opposite of what I need. And negative numbers produce no effect whatsoever. – TiGR May 18 '15 at 20:42
0

Install pulseaudio in your system using:

apt-get install pulseaudio

Open pulseaudio volume control from the applications menu. Goto the Output devices tab. Identify the sound device that is currently running. Expand the Advanced option dropdown. There you will be able to enter, increase or decrease the latency directly.

If any of the steps goes wrong or buggy, consider closing everything and restarting pulseaudio with:

pulseaudio -k

Important: Consider reading this answer before trying it out: (K)Ubuntu 17.10 - No Audio devices found, no settings, no sound #Answer

1
  • Thanks, but it does the opposite of what I need. I have a problem of video appearing later that the sound. So if I add a delay there, the delay from sound to video only increases. You might think that putting negative values there might do the trick, but that does nothing. – TiGR Apr 10 '20 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.