5

I've been having this issue with Firefox Developer Edition (FDE) on Youtube, where it show videos only in 360p quality, there's also an "Auto" option, which is also, the 360p quality. I'm in Ubuntu 14.04 LTS.

Here's an example of a video that I know is in higher quality because I can see it with Chromium and with youtube-dl.

On FDE:

youtube on FDE

On Chromium and youtube-dl:

youtube on Chromium and y-dl

What could be the cause of this?

I have installed the Adobe flash plugin and I keep all my packages up to date, including my version of FDE (40.0a2, updated 18th may 2015).

I want you to know that "switching from FDE to Chromium" is not the solution to this question and I will not mark those posts as the answer.

I tried deleting every Youtube and Google account related cookies but it didn't solve the issue.

  • Any change if you disable the Flash plug-in in Firefox? – user3169 May 18 '15 at 17:38
7

Try installing this add-on onto your Firefox.

  • Since I installed it I've been able to watch videos in better quality on Firefox Developer Edition, thank you. – favourites May 23 '15 at 17:03
  • Very painless solution ^^ – displayname Oct 22 '15 at 10:53
  • very best solution – Sameera Kumarasingha Oct 27 '15 at 16:58
2

Go to about:config in Firefox and set the following properties to true:

  • media.mediasource.enabled
  • media.fragmented-mp4.exposed
  • media.fragmented-mp4.ffmpeg.enabled

To check if it worked you can go to https://www.youtube.com/html5. You should see something like this:

Supported modes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.