1

When pasting some text, it often doesn't paste the most recently copied text, but something from earlier. This happens even when copying and pasting within the same application.

I'm using 15.04, but I've had this problem in 14.10 also. I've tried using other clipboard managers (glipper/clipit) and the problem persists. I've also tried installing parcellite.

According to clipit, copying text always registers but sometimes I can't paste. Usually what I need to do is button-mash Ctrl+c and then it works.

What's more sometimes it even becomes impossible to select text. The selection disappears immediately after releasing the mouse/keyboard (most often in gedit and nautlius). This might be an unrelated problem, however.

I often switch between Unity and i3wm, and I never had either of these problems in i3wm.

4
  • I'm seeing the same problems. Clipit registers the correct copy/cut action, but the paste operation produces the wrong (older) object. It is a system-wide problem, and I know of no way to debug it.
    – Jos
    Jun 9, 2015 at 10:23
  • @Jos Thanks for the reply. I've switched to using i3wm permanently as a result which works flawlessly, though I will try a fresh install soon. Jun 10, 2015 at 14:38
  • This may be a long shot but have you installed Pushbullet? As one of its functions, it synchronizes clipboard actions from your mobile phone to the PC and vice versa. I'm suspecting that that may give problems.
    – Jos
    Jun 11, 2015 at 6:11
  • It turns out I have. I'll get rid of that and see how things work. Thanks! Jun 12, 2015 at 12:43

1 Answer 1

1

As suggested by Jos in the comments, uninstalling the Pushbullet indicator solved the issue. I'm now using the Firefox/Chrome pushbullet extension instead (with universal copy & paste disabled) and everything is now working fine.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.