2

I used to run the default VNC server (/usr/lib/vino/vino-server) but it is unable show VirtualBox VMs. So, I have installed TurboVNC, which is designed to support 3D and shows my VirtualBox VMs all right.

However, TurboVNC and all these other TightVNC derivatives run on 5901 or 5902. I would like to make them run on 5900 but there doesn't seem to be an option to do so.

How can I run Turbo, Tiger, Tight VNC servers on port 5900. If I could do this, then I could make TurboVNC the default VNC server on several computers and VMs.

(I know that VirtualBox has an RDP option but I want to see the host desktop along with the VMs too. So, TurboVNC on the host is my choice.)

4

For TightVNC the default port is 5900 plus the display number, so 5901 for the first display, etc.

The server has an undocumented command-line option to override this port number

-rfbport 5900

Should manually set the port number to 5900. Experiment with it.

  • 1
    +1... the option is not really undocumented though: it's an option that's passed transparently to the underlying Xvnc process, and is documented under man Xvnc – steeldriver May 18 '15 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.