2

I just installed ubuntu 15.04 (3.19.0-16-generic #16-Ubuntu) on my ThinkPad X1 Carbon - 20A7CTO1WW (2nd Gen).

Hibernation works (occasionally. not all the times) with sudo pm-hibernate but not when closing the lid. On 14.04 I had to modify 2 files to make it work but now it's no longer working. Here are the modifications that used to work on 14.04:

  1. In /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla: replace
[Disable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=no

[Disable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit
ResultActive=no

by

  [Re-enable hibernate by default in upower]
  Identity=unix-user:*
  Action=org.freedesktop.upower.hibernate
  ResultActive=yes

  [Re-enable hibernate by default in logind]
  Identity=unix-user:*
  Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.lo
  ResultActive=yes
  1. In /etc/systemd/logind.conf: replace

#HandleLidSwitch=suspend

by

HandleLidSwitch=hibernate

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.