1

I am trying to connect to an Xauth Ipsec VPN, I have entered all my relavent infromation and the VPN seems to fail without an error that I can debug.

Uses Username/password, Group name and then a mutual PSK between all users.

Error:

May 17 15:24:11 xps NetworkManager[824]: <info> Starting VPN service 'vpnc'...
May 17 15:24:11 xps NetworkManager[824]: <info> VPN service 'vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 4082
May 17 15:24:11 xps NetworkManager[824]: <info> VPN service 'vpnc' appeared; activating connections
May 17 15:24:11 xps NetworkManager[824]: <info> VPN plugin state changed: starting (3)
May 17 15:24:11 xps NetworkManager[824]: <info> VPN connection 'VPN connection 1' (Connect) reply received.
May 17 15:24:11 xps NetworkManager[824]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/tun0, iface: tun0)
May 17 15:24:11 xps NetworkManager[824]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/tun0, iface: tun0): no ifupdown configuration found.
May 17 15:24:11 xps NetworkManager[824]: <warn> /sys/devices/virtual/net/tun0: couldn't determine device driver; ignoring...
May 17 15:24:12 xps charon: 10[KNL] interface tun0 deleted
May 17 15:24:12 xps NetworkManager[824]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/tun0, iface: tun0)
May 17 15:24:12 xps NetworkManager[824]: <warn> VPN plugin failed: 1
May 17 15:24:12 xps NetworkManager[824]: <info> VPN plugin state changed: stopped (6)
May 17 15:24:12 xps NetworkManager[824]: <info> VPN plugin state change reason: 0
May 17 15:24:12 xps NetworkManager[824]: <info> Policy set 'homeWIFI' (wlan0) as default for IPv4 routing and DNS.
May 17 15:24:12 xps NetworkManager[824]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
May 17 15:24:17 xps NetworkManager[824]: <info> VPN service 'vpnc' disappeared

If anyone can give me any pointers into debugging further, I would be very grateful :)

1 Answer 1

0

Probably is the problem with libgcrypt11 Try to upgrade or rool back version of libgcrypt11.

Curent version of libgcrypt11 you can see with command

dpkg -s libgcrypt11
4
  • Hmm, I have the latest version "Version: 1.5.3-2ubuntu4.2" as of: launchpad.net/ubuntu/+source/libgcrypt11
    – Cro0ksey
    May 18, 2015 at 16:51
  • Try with older version of lib.
    – 2707974
    May 19, 2015 at 13:11
  • I'm having the same issue with version 1.5.3-2ubuntu4.2 on Linux Mint 17.1. This morning my connection to the VPN worked fine, my machine went to sleep and now I can't reconnect, even after a clean reboot.
    – Greg K
    May 21, 2015 at 16:30
  • doesn’t help, still having problems through the GUI or the command line.
    – Cro0ksey
    Jun 17, 2015 at 20:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .