1

I am very new to Linux and am using LXDE (Ubuntu 12.04.5 LTS) and seem to have a problem installing spotify. I have looked around and couldn't find this specific problem, I hope I am not asking the question while it has already been resolved.

I have the feeling I do everything as it should be done, using the terminal I add the following to the bottom of the repository:

deb http://repository.spotify.com stable non-free

(for instance using sudo gedit /etc/apt/sources.list or an echo command)

I then run:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4E9CFF4E

Than:

sudo apt-get update 

And finally:

sudo apt-get install spotify-client

This gives back the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package spotify-client

I am really new to Linux so I have no idea if this means my repository is not correct or if the actual package doesn't exist anymore or something else.

  • 1
    Are you using a 32 or 64 bit system? If you don't know, look it up by executing file /sbin/init, there will stand something like ELF 64-bit LSB... – s3lph May 17 '15 at 10:49
3

If you are running a 32-bit system, you may be out of luck. If you have a look at the Spotify repository, you'll see the following files:

spotify-client-0.9.17_0.9.17.8.gd06432d.31-1_amd64.deb
spotify-client-gnome-support_0.9.17.1.g9b85d43.7-1_all.deb
spotify-client-qt_0.9.17.1.g9b85d43.7-1_all.deb
spotify-client_0.9.17.1.g9b85d43.7-1_amd64.deb

As you see, the package spotify-client only exists for the amd64 architecture, i.e. 64-bit CPUs and systems.

The other two packages are packaged architecture-independently, but they will not provide you with the spotify client. They are transitional packages, which do not provide the Spotify client, as one can see from the package description:

Description: Transitional package for spotify-client
 This transitional package is provided for a smooth transition from the previous
 spotify-client-gnome-support package.  It may safely be removed after installation.

To be able to use the spotify-client package and the binaries in it, you need at least a 64-bit kernel, but it may be easier to install the complete system as 64-bit. If your CPU doesn't support 64-bit, you are out of luck...

If you really want to go through the procedure of making your system 64-bit compatible, you'll find various instructions on the internet. I will, however, not provide one here, because I don't want to be responsible if you run in trouble.

| improve this answer | |
  • Thanks for your answer. The installation is indeed 32 bit. I am not sure if the cpu has 64 bit architecture. I'll have a look into that, see if it is even possible to go to 64 bit os. – Steen May 18 '15 at 20:46
2

I'm using Lubuntu 15.04 (i386 32 bit) and I installed (emulated) Spotify thanks to winetricks. It's a solution for 32-bit users.

| improve this answer | |
2

To anyone having this issue on a 64-bit architecture, remove the existing aptitude source, update then re-install. I'm not sure what went wrong the first time I tried to install, but this worked for me.

  1. rm /etc/apt/sources.list.d/spotify.list
  2. apt-get update

Now re-install using these instructions: https://www.spotify.com/ca-en/download/linux/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.