0

I am running Ubuntu 14.04 LTS 64-bit and the version of Firefox that comes with this version of Ubuntu. I recently went to a website and got a notification that my version of Firefox was no longer supported. I was not aware that Firefox was not being updated as I update regularly. I tried updating from the command line as well as using the Ubuntu Software Updater but neither of these work and my Firefox version is still stuck. I have researched online and have tried adding the Firefox security PPA as well and installed that but when I launch Firefox it is still the same old version that opens.

  • What version of Firefox do you actually use? – s3lph May 16 '15 at 22:56
  • What message is returned when you try to update it from command line? And/or what do you see when you try it from the software center? – juanjalvarez May 16 '15 at 22:57
  • Firefox in 14.04 is at ver. 38, quite doubtful that any website would call it " not supported". Maybe take a closer look at what your issue is or post a link to this website. – doug May 16 '15 at 23:50
  • Maybe it's got to do with "Flash"? Some sites want the latest-n-greatest version available by default with Google Chrome. – DK Bose May 17 '15 at 1:59
  • I think it's just an ad. What's the site? – TheWanderer May 17 '15 at 2:07
3

I eventually tracked down the issue to a plugin I had installed a while back that allows you to modify the header information to look like your using a different OS and browser so the sites I visited were thinking I was on Windows and using an older version of Firefox.

2

Firefox 38 is the latest version. I'm pretty sure, if it's a ribbon at the top, or a box in the site, that is an ad. Ignore it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.