4

I just started using ubuntu.

every time I want to start|stop|restart a service I get this error:

systemctl: /usr/local/lib/libgpg-error.so.0: no version information available (required by /lib/x86_64-linux-gnu/libgcrypt.so.20)

I did google but I could not find anything helps me.

I realized the problem after I did some changes to apache2 config file and needed to restart the service.

$ apt-cache policy libgpg-error0
libgpg-error0:
  Installed: 1.17-3ubuntu1
  Candidate: 1.17-3ubuntu1
  Version table:
 *** 1.17-3ubuntu1 0
        500 http://ir.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy libgcrypt20
libgcrypt20:
  Installed: 1.6.2-4ubuntu2
  Candidate: 1.6.2-4ubuntu2
  Version table:
 *** 1.6.2-4ubuntu2 0
        500 http://ir.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
  • Edit your question and add the output of apt-cache policy libgpg-error0 and apt-cache policy libgcrypt20 – A.B. May 16 '15 at 13:58
1

The problem is, you have an additional library in /usr/local/lib/:

/usr/local/lib/libgpg-error.so.0

Clarify why you have installed this library. Then you have two options:

  1. Remove the library (backup)

    and your system takes the version in /lib/x86_64-linux-gnu/

    sudo mv /usr/local/lib/libgpg-error.so.0 /usr/local/lib/libgpg-error.so.0.bak
    
  2. Remove the library and create a symbolic link

    if you need the library in /usr/local/lib/

    sudo mv /usr/local/lib/libgpg-error.so.0 /usr/local/lib/libgpg-error.so.0.bak
    sudo ln -s /lib/x86_64-linux-gnu/libgpg-error.so.0 /usr/local/lib/
    
  • Too bad OP never said where it came from... – Fabby Aug 25 '15 at 19:30

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.