2

I get the following response launching steam

 The following packages have unmet dependencies:
     libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
     unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                            Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
1

I looked back through my terminal history and this is what I did prior to making the post:

sudo apt-get remove --purge steam-launcher

I then restarted the computer and downloaded a fresh copy of the .deb installer for Steam from https://steamcdna.akamaihd.net/client/installer/steam.deb

After installing, it went through the same process and failed to find and install those packages. This time however, the Steam login window popped up (after a lengthy update) and I was able to login.

I am currently downloading a game now to test further. I hope this solution helps.

Update: I still get the error everytime I launch Steam, but Steam still works everytime. I have downloaded and played Borderlands 2 successfully.

|improve this answer|||||
1

I had the same issue in installing Steam using the proprietary drivers downloaded from Nvidia. Instead, I used the proprietary drivers in the "Additional Drivers" application within Ubuntu and installed the latest one listed. Then I ran the following commands pressing Enter after each line before installing steam:

sudo dpkg --add-architecture i386
sudo apt-get clean
sudo apt-get update

Then I finally installed Steam with no issues.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.