19

Using 15.04

When I connect my phone to my PC, I get a message popup saying that Ubuntu was unable to mount the device - however I'm able to access the storage on my phone to add/remove files etc.

How can I stop Ubuntu from displaying this specific error message? Some sites suggest turning off all error messages altogether which I'd rather not do, others talk about unlocking my phone before plugging it in which I do already, but this message still appears.

3
  • Can you add a screenshot (Picture?) of the error and the specific brand/phone you're using in addition to the output of lsusb?
    – Fabby
    May 19 '15 at 6:54
  • It shows "Could not connect MTP device (usb 002:007). But the phone coorectly connects, both internal and external flash drives are shown. I have an HTC phone. Lsusb shows it connected, but on 002:008.
    – Pilot6
    May 22 '15 at 18:02
  • Related: to stop automount entirely: askubuntu.com/q/89244/762119
    – Justin
    May 21 '18 at 17:12
8
+25

Interesting question I upvoted it ;) I actually have an Android device and this message pops up all the time I connect my device but I don't pay any attention to it. There's a tweak workaround to play with is USB dubugging mode inside Android System Settings navigate to Applications/Development there you'll find USB debugging.

When you connect your phone the first time and USB debugging is ticked it's not actually right.

Firstly, untick/unmark USB debugging mode on your Android device, the message will appear:

Press OK on notification message and unplug USB cable. Now plugin USB cable click OK again on notification message and inside System Settings where USB debugging at put a tick/mark on and press OK on your Android notification message and press OK on desktop notification (if any popped up). That's basically it, now unplug and plug USB cable as many times as you want the notification message should not appear. I also tried to logout and login to a new session and the notification message didn't appear either.

6
  • 1
    This does not work for me. I think it hast be done in udev rules, not by clicking back and forth.
    – Pilot6
    May 24 '15 at 8:14
  • Well I have no idea even after complete poweroff when I plugin USB this message doesn't appear anymore. If I undo my steps the notification pops up again. I guess if this work for my Samsung Galaxy device it might be that various devices have to be tweaked differently in that case making this question too broad for the answers or only possible to test by user who has exactly the same devices and issues as stated in the OP.
    – JoKeR
    May 24 '15 at 9:28
  • And with my phone debugging is off by default. I tried to toggle it too, but that does not change anything, except usb numbers differ in the error message.
    – Pilot6
    May 24 '15 at 9:43
  • Well as I said different tweaks for different devices ;) when I'll have HTC device next to me I'll try workarounds with that one.
    – JoKeR
    May 24 '15 at 9:46
  • @Pilot6 look at this confirmed bug here as it stated the status confirmed and it affects lots of users. And in comments you'll find an HTC user comment that toggling USB has helped him also.
    – JoKeR
    May 24 '15 at 9:57
2

This worked for me on Ubuntu 14.04:

On the Android device, under Settings->Networking, select USB Configuration and change it from "Charging" to "MTP" (Media Transfer Protocol)

No more pop-ups!

2

On my Samsung Galaxy S7, I was able to go into the developer options and simply change the "USB Configuration" option to "Charging". It took care of it for me. I also had previously disabled the device through udev.

2

On Ubuntu 16.04 this procedure worked for me:

  1. Enable developer options
  2. Settings > Developer Options > Select USB Configuration
  3. Select MTP

Now you should see the file manager showing the internal/external SD card mountpoints.

2
  • +1 for the exact path on the Android side. In my case MTP was already selected when I had this issue, and turning it to Charging solved.
    – IsaacS
    Jun 23 '17 at 14:15
  • I have asked a question "ADB finds no devices and MTP does not work" as this thread does not cover that question even though it addresses the "Unable to mount ..." popup.
    – John Rose
    Aug 30 '17 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.