0

Since I'm using Ubuntu I'm having problems with the wifi. It connects correctly, and I can use internet for some time, but suddenly the internet stops working. It says that it's connected, the icon tray is normal.

I have noticed that if I turn off the wifi of my phone and turn it on again, in the exact same time that it connects to the internet, the wifi on the desktop start to work again. It happens every time.

The desktop wifi stop working even if the phone is turned off, but the only way to make it work again is connect to the internet with the phone.

I have a USB wifi adapter and Ubuntu 15.04

output of "uname -a"

Linux renan-POS-EIH61CE 3.19.0-16-generic #16-Ubuntu SMP Thu Apr 30 16:09:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

output of "lsusb"

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 003: ID 056a:0302 Wacom Co., Ltd 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Output of "lsmod"

Module                  Size  Used by
rt2800usb              28672  0 
rt2x00usb              24576  1 rt2800usb
rt2800lib              94208  1 rt2800usb
rt2x00lib              57344  3 rt2x00usb,rt2800lib,rt2800usb
mac80211              720896  3 rt2x00lib,rt2x00usb,rt2800lib
cfg80211              540672  2 mac80211,rt2x00lib
crc_ccitt              16384  1 rt2800lib

How can I solve this?

  • Please give output of "lspci -knn | grep Net -A2" in terminal. – Pilot6 May 15 '15 at 15:33
  • Please edit your question and place THERE the output of this command. It is one command, not two. Just copy it and paste to your question. – Pilot6 May 17 '15 at 13:14
  • I do not see any internal wireless adapters there. Is it a USB dongle? Then give output of "lsusb". – Pilot6 May 17 '15 at 13:16
  • @Pilot6 Guess what ? he is sharing is phone wifi to the pc without knowing it. Renan: If you are not sharing you phone wifi, it is more likely a problem with your modem/router than ubuntu. – solsTiCe May 17 '15 at 14:24
  • I have tried the command you said Pilot6 as one command, but it gave no output, nothing happens. But as I really have a wifi usb adapter, now I tried "lsusb - knn | grep Net -A2" , I don't know it is what I should do, I think it's not, because it says is an invalid entry XD. Anyway, there's output only with the command "lsusb" alone, which output is now on my question. – Renan May 18 '15 at 14:16
0

I can suggest only one solution. If it does not work, then it is impossible to use this Ralink dongle with Ubuntu. Run in terminal:

sudo modprobe rt2800usb nohwcrypt=1

Then unplug and plug in the dongle again. If this helps, then get it permanent.

echo "options rt2800usb nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800usb.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.