1

This question has been solved. Thank you for all your help. The solution was just to downgrade. Didn't even need to install the OS for it to work, it worked inside the installer.

My mother's old laptop was running Windows 7. For one reason or another, she decided she didn't want it, so I took it and installed Ubuntu 15.04 on the laptop. Now before I did this, her Wireless Card inside the laptop went out (For one reason or another, we don't know), so we bought a little USB WiFi Adapter. It's a netgear for anyone wondering. The installation went perfect without any hitches, expect the WiFi won't work. Now I'm not saying it's 100% dead, that's anything but true. I can still scan for networks and see them in the network list, but when I try to connect to my hidden network, using WPA2-PSK [AES], it will keep doing the little "connecting" animation in the status bar, then after about 10 minutes, stop, and quit trying to connect. Is there anyway I can connect to my Internet? Also, I do NOT have access to Ethernet at the time. I can get access, but it would take me a while. My main goal is to actually be able to use the WiFi Adapter, so I can take the laptop places and connect to WiFi. Thank you for any and all help!

EDIT: The output of "lsusb" is as followed:

Bus 001 Device 002: ID 0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

EDIT 2: I have connected the laptop to Ethernet to apply updates, since I wasn't able to during the installation process (The USB wouldn't work during then either). Currently it is doing updates in my garage, where my router is located. Long story short, I have access to internet temporarily

EDIT 3: Ubuntu 14.04.02 worked just fine. I didn't even have the operating system installed and I was able to connect through the installation screen. I guess 15.04 doesn't have the necessary drivers, or they don't support the new kernal. Either way, I have successfully connected. Now to do some ping tests after the install is complete. :)

  • Please add output of "lsusb" to your question. – Pilot6 May 14 '15 at 21:46
  • Okay, give me one second. – TerrorByte May 14 '15 at 21:46
  • Output of lsusb has been added to the main body of the question. – TerrorByte May 14 '15 at 21:52
1

You can install the driver this way. Connect to Ethernet and run in terminal:

sudo apt-get install git
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install

And reboot. Wifi should work.

  • My question is, though, will this work for Netgear? I looked it up, and this seems to be for Realtek... – TerrorByte May 14 '15 at 22:03
  • Netgear is the manufacturer of the dongle. Realtek made the chip. This specific dongle is supported by this driver. – Pilot6 May 14 '15 at 22:05
  • Okay, I did that. Now whenever I try to connect to a hidden network, the computer locks up... – TerrorByte May 14 '15 at 22:09
  • Maybe it makes sense to unhide the network and set WPA2-AES encryption instead? – Pilot6 May 14 '15 at 22:11
  • I cannot unhide the network, because I don't want it shown, and it is already set to WPA2-AES encryption. – TerrorByte May 14 '15 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.