2

I have been running ubuntu 14.04, then 14.10 on my Intel NUC model DN2820FYKH for months without any issues. I recently reformatted and reinstalled a fresh copy of 15.04, and after doing so I am now unable to reboot or shutdown, via terminal or from the GUI. Upon doing either, I get the purple loading screen, and there it stays. One difference I've noticed is that while shutting down, the progress bars appear to move for a while before freezing. When rebooting, they never move at all. I have to go to the box, hold down the power button, then turn it back on.

So far I have run all updates, and tried the following solution:

Ubuntu 15.04 freezing on shutdown/reset and having problem with Nvidia

This appears to be the same issue:

14.10 to 15.04 upgrade, now I can't poweroff or reboot!

update: I tried adding acpi=force to my grub file as detailed here:

Shutdown does not power off computer

This did not fix the issue.

  • try to add this GRUB_CMDLINE_LINUX='acpi_enforce_resources=lax' to GRUB and then run sudo update-grub – JoKeR Jun 30 '15 at 8:43
  • Thanks for the suggestion. Still not fixed, although now I can see that the freeze occurs after "reached target shutdown." A quick Google search seems to show that my intel NUC bios just doesn't recognize the shutdown command being issued, although it worked on previous ubuntu versions. I tried the latest BIOS update from intel, which is only a week or so old, but same result. – eljefe Jul 2 '15 at 4:24
  • in this case if it's might be a bug you could post it to Launchpad also. – JoKeR Jul 2 '15 at 11:18
1

You need to do the following for the NUC model DN2820FYKH

Update the BIOS to version FYBYT10H.86A.0055

download the update from Intel here

Then add reboot=bios as a boot parameter:

sudo -H gedit /etc/default/grub

Find the line that begins GRUB_CMDLINE_LINUX_DEFAULT= and change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios"

Save and exit, and run

sudo update-grub

Then reboot. This worked on Xubuntu 16.10 for me.

0

UPDATE:

Reboot only worked between the BIOS update and a poweroff. After that one poweroff and restart, reboot no longer works. Updated BIOS does not fix the issue.

I am now using this script to force a reboot if really needed (its a development machine)

#!/bin/bash

service mysql stop
service apache2 stop

sync
sleep 1
sync
sleep 1

echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger

old bad answer follows.

I had this same problem with this NUC model: NUC DN2820FYKH

Upgrading to version 52 of FYBYT10H.86A BIOS fixed the problem.

Download link: https://downloadcenter.intel.com/es/download/25448/Actualizaci-n-de-BIOS-FYBYT10H-86A-

  • UPDATE: I downgraded the newer-bios NUC to kernel 3.13.0-24 and it now reboots just fine. Maybe an incompatibility between newer BIOSes and newer ubuntu kernels? – Eduardo Kaftanski Feb 11 '16 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.