1

I was applying updates to my AWS Ubuntu 14.04 servers. I used this command:

sudo apt-get update

It work for all of them, except one server.

I get this error at the end:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/main/binary-amd64/Packages  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.91.23 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried to do an upgrade. I ran this:

# sudo apt-get upgrade

I saw this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  lxc-docker
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

What should I do to get the updates to apply?

3
  • Raring is 13.04, not 14.04. Perhaps you have some spurious sources, or you're actually on 13.04.
    – muru
    May 14, 2015 at 2:20
  • What should I do about spurious sources? I am running 14.04. I did this command to prove it: lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty
    – PJ8912
    May 14, 2015 at 4:54
  • Delete them. Do grep raring /etc/apt/sources.list* -R, find the offending entries and remove them.
    – muru
    May 14, 2015 at 4:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.