A few weeks ago, I built a desktop and installed Ubuntu 15.04 and have been battling with it ever since. There seems to be an issue with the compatibility of the NVIDIA drivers and Ubuntu.

(After weeks of struggling with various black/purple screens, toggling nomodeset, blacklisting nouveau, and restarting lightdm/trying gdm, returning my GTX960 for a GTX750TI, installing Ubuntu 14.04 and 14.10, login loops, and a few other things I'm sure I forgot, I have the following minimal example.)

  1. I create a boot USB with Ubuntu 15.04.
  2. I select "Install Ubuntu" (note that I must edit the options for this, changing "quiet splash" to "quiet splash nomodeset" or else it doesn't work).
  3. After installing Ubuntu, I am asked to restart. I can boot in recovery mode (although the resolution is strange), but not normally.
  4. At this point, I have tried various things (reinstall nvidia drivers, permanently add nomodeset to boot options, etc.), most of which end up leading to the need to reinstall Ubuntu from scratch due to inability to see anything without removing the graphics card and plugging the monitor into the motherboard.

I have just completed the first 3 steps, which are by now muscle memory, and am begging for suggestions on a new step 4.

EDIT: I have tried the steps here (which led me to the nomodeset option that allows me to see the screen while I install Ubuntu) but when I update the NVIDIA drivers (I have tried both the proprietary and non-proprietary versions, many different version numbers), this leads me to other problems. Most often, it is a login loop, but occasionally it is a black/purple screen. When I follow the suggested to address the login loop, this invariably leads me back to a blank screen and I then reinstall Ubuntu.

$ sudo lshw -C video
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: GM107 [GeForce GTX 750 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff

Update: installing bumblebee allows me to escape the login loop. The resolution of my monitor still doesn't look right, and I have to click out of about a dozen "Report system problem" boxes.

Edit: My xorg.log is here.


7 Answers 7


I too built a desktop, and used the 750Ti. I had the exact problem that the OP has, and I can personally testify that the below worked for me. I don't have a ton of time, so I'll have to summarize. When in doubt, Google is your friend.

  1. Go to NVIDIA's website from another PC and download the appropriate driver to a USB drive.

  2. Plug this USB drive into your desktop and boot. At the login screen, enter runlevel 2 by pressing CTRL+ALT+2

  3. Now you will be in a terminal (fun times!). Login using your account.

  4. Kill lightdm.

  5. Mount your USB drive and un-tar the driver.

  6. Run the driver installer. If there are no errors during installation, then reboot. The login loop should now be gone.

This makes it sound simple, but unfortunately, it is actually pretty difficult. It took me four tries to get it right.

Let me know how this works for you!


OK,Lets understand the point number 2 you mentioned, You said that you had to pass nomodeset kernel parameter while Booting off of the USB.

This would Indicate that the Graphics Card you have GTX750TI, Does not want to work well with the Open Source Nouveau Driver. So that is your First Problem. I would not Proceed with the Install if I had to use nomodeset just to boot into the Installer.

I don't have experience with this card but the Maxwell Architecture which it is based on has a lot of issues with Nouveau Driver which is Open Source.

Ubuntu By default ships with Open Source Drivers and if your Card has issues working with it you will see black screens etc..

What is the best way to confirm this?

Please download Manajaro Linux and while booting select non free drivers you will get a confirmation. You could also try Archlinux which has the 4.0 Kernel and many Graphics related issues are fixed in that release.



  • Yes, in the past I've gotten Archlinux to work. As mentioned in the post, I have installed many proprietary drivers compatible with my card, but these lead to other problems, most commonly log-in loops and black screens.
    – Gschneider
    May 19, 2015 at 17:33
  • Have you tried Bumblebee. I have written a good Article for it on Ask Ubuntu Question. askubuntu.com/questions/452556/… If your Laptop has Optimus then your best chance is bumblebee. Because it knows how to handle Your Card. Please give bumblebee a chance and I think you will not have any black Screens and Login Loops. Many people have confirmed it as working. Many times installing only the Nvidia Proprietary Driver is not enough if you have Hybrid Graphics on your Laptop Which I think you have. Please try it and let us know May 19, 2015 at 18:47
  • I'm using a desktop, and I've shut off the motherboard's graphics, but thank you for your suggestion, this is something I haven't tried.
    – Gschneider
    May 19, 2015 at 20:08
  • For step #7, are i915 and bbswitch two separate lines?
    – Gschneider
    May 19, 2015 at 21:04
  • Seems like bumblebee causes problems of its own... when I plug in my monitor via HDMI, the resolution is an unusable 640x480. When I use DVI, it becomes unbearably laggy.
    – Gschneider
    May 19, 2015 at 22:41

I think it's because of kernel version. As you know the kernel version of Ubuntu 15.04 is 3.16. Try use a live Linux with updater version. (for example arch).

I had seen this problem with Ubuntu 14.04 and lenovo flex II.


well actually i had same problem tried so many times with so many ways... non result..

but finally i just installed this driver version directly

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get install ppa-purge
sudo apt-get update
sudo apt-get install nvidia-334
sudo apt-get install nvidia-334-uvm

that's all

im not sure if this will work for you im not a pro but it works for me and i though should notice it here

but im sure that driver version is same coz im running steam games and etc. running very well which you can find source package here:


hope it works


I had a problem like this, when I updated to 15.10. It turned out that the problem was the NVIDIA card was overheating to about 30% more than suggested temp. Get a live disk install, and install psensor to check temperatures of the video card.


I had a similar problem after installing an nvidia card in an existing 15.04 machine. After struggling for some time, looking for answers here and finding nothing that really helped, I gave up and installed 14.04 (LTS). The nvidia drivers were installed automatically and everything works like magic. (See Problems installing Nvidia drivers, Ubuntu 15.04)

From your question it seems that you did exactly what eventually solved my problem, except that you installed a fresh 15.04 while I installed a fresh 14.04. I suspect that 15.04 has a specific problem. So installing 14.04 could be a solution for you.


I have had the same problem, and you need a fresh installation, and first enter the bios and set the boot from uefi to legacy, and not a secure boot, and then install Ubuntu again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .