7

I'm currently upgrading my system over SSH

And it asked me to upgrade to a new version of ports.conf, I choose the option to compare the two differences..

How do I get back out of this without cancelling the upgrade?

  • 1
    You are probably viewing the output of diff file1 file2 | more. Press q to exit. – Jos May 13 '15 at 9:25
  • Amazing - so simple. Thank you @Jos, if you want to add it as an answer i'll accept. – CᴴᵁᴮᴮʸNᴵᴺᴶᴬ May 13 '15 at 9:27
  • Doesn't work. Tried Q, q, ctrl-Q, ctrl-q. It responds to the up and down arrows, and shows an <ok> as if it's a button, but nothing lets me exits that screen. – John Smith May 24 at 6:05
12

You are viewing the output of diff old-conf-file new-conf-file | more.

Simply press Q to exit.

| improve this answer | |
  • Upper case is a solution. – Yevgeniy Afanasyev May 13 '19 at 4:25
  • 1
    Not for me. Neither upper nor lower case Q do anything at all. – John Smith May 24 at 6:05
  • @JohnSmith I had the same problem, that no key made me quit that comparison mode. I tried it multiple times, also with "Command" + "Shift" + "Q", but nothing happened. Finally, I tried simply a (lowercase) "q" again and it worked. I could not tell you more about it unfortunately but it seems that one can solve it just by trying the same combination multiple times (perhaps after having triggered something else unconsciously by so doing). – IndexOutOfBoundsException Jun 13 at 7:50
0

Press 'Esc' key worked upgrading an old 14.04 system

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.