So I had Crossfire running on 14.04, but I decided to update to 15.04 and now it's acting strange. I've gone through the typical steps of commenting out everything in /etc/init/gpu-manager.conf, and I've ran through the process of executing:

sudo aticonfig --initial -f
sudo aticonfig --adapter=0,1 --cfa
sudo aticonfig --adapter=0,1 --crossfire=on

multiple times and each time the Crossfire bridge shows up when I run:

aticonfig --lsch

However, any time lightdm restarts, either during a reboot or restarting lightdm manually, running aticonfig --lsch again returns No Multiple GPU chains defined.

I've even gone so far as to replace /bin/gpu-manager but even then the problem persists. The issue also doesn't appear to be with the /etc/X11/xorg.conf file because it doesn't get overwritten anymore.

1 Answer 1


Double check that IOMMU is not enabled.(in bios) When IOMMU is enabled,after reboot enabled amd crossfire will be disabled. And kernel will give you message: to enable crossfire ,please disable IOMMU..

lspci | grep IOMMU   #output must be noting

IOMMU can be switched off in bios ,or with passing iommu=off to kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.