Part 1

I upgraded 2012 MBA to 2015 MBPr (I loved Mint 17.1 Rebecca on the MBA but graphics/kernel issues means I need to wait till 17.2 to use Mint again)

I've managed to install Ubuntu on an SDcard. It boots and works. Great tutorial on this is Installing Ubuntu 15.04 on a Macbook Pro 11,2.

I cannot get the Wi-Fi to work.

Used Terminal to determine the chipset:

$ lspci -nn | grep 0280
03:00.0 Network controller [0280]: Broadcom Corporation BCM43602 802.11ac Wireless LAN SoC [14e4:43ba] (rev 01)

I tried enabling the driver in Software & Updates → Additional Drivers. Ubuntu freezes so that's a no go.

I used terminal to install the following blobs/drivers (not sure what you call them) offline:

sudo dpkg -i bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu2_amd64.deb dkms_2.2.0.3-2ubuntu3_all.deb

This caused the system to freeze at:

DKMS: install complete

I rebooted and tried reinstalling using Ubuntu Software Installer which caused it to hang.

I've not messed with anything else. Can someone please explain what I am doing wrong?

Okay, here's part 2:

I tried installing bcmwl-kernel-source_6.30.223.30+bdcom-0ubuntu3_amd64.deb.

This is the error message:

Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 170952 files and directories currently installed.)
Preparing to unpack bcmwl-kernel-source_6.30.223.30+bdcom-0ubuntu3_amd64.deb ...
Unpacking bcmwl-kernel-source ( ...
Selecting previously unselected package dkms.
Preparing to unpack dkms_2.2.0.3-2ubuntu3_all.deb ...
Unpacking dkms ( ...
Setting up dkms ( ...
Setting up bcmwl-kernel-source ( ...
Loading new bcmwl- DKMS files...
First Installation: checking all kernels...
Building only for 3.19.0-15-generic
Building for architecture x86_64
Building initial module for 3.19.0-15-generic
ERROR (dkms apport): kernel package linux-headers-3.19.0-15-generic is not supported
Error! Bad return status for module build on kernel: 3.19.0-15-generic (x86_64)
Consult /var/lib/dkms/bcmwl/ for more information.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for man-db ( ...
Processing triggers for initramfs-tools (0.103ubuntu15) ...
update-initramfs: Generating /boot/initrd.img-3.19.0-15-generic

I then tried:

$ sudo modprob wl
sudo: modprobe: command not found

I checked and apparently the driver is recognized as installed:

~$ sudo lshw -C Network
*-network UNCLAIMED     
   description: Network controller
   product: BCM43602 802.11ac Wireless LAN SoC
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: latency=0
   resources: memory:c1400000-c1407fff memory:c1000000-c13fffff

So here I am, no Wi-Fi, not seeing any network ID...

I've Googled and found a few other people who've managed to get Wi-Fi working using the same blobs/drivers.

Can someone please shed light on why this is not working?

Also, why is the Apple Thunderbolt Ethernet Adapter not recognized, that thing came out years ago and it would make this processes a lot easier if I could at least get online to look up fixes, etc.


1 Answer 1

  1. Uninstall your previous attempted:dpkg -r bcmwl-kernel-source
  2. Downloaded the brcmfmac43602 firmware from the Linux firmware git repo.
  3. Create the folder /lib/firmware/brcm if it doesn't already exist.
  4. Copy the file to /lib/firmware/brcm
  5. Reboot and enjoy your WiFi.


You might have to run apt-get update and apt-get upgrade.

I have a simple USB to Ethernet adapter from Moshi that works out of the box, but in your case you could always add the driver to the SD card. Add a small FAT32 (using GParted) or exFAT partition (make free space using GParted and format exFAT with OS X Disk Utility) on your SD card to make sharing files between OS X and Ubuntu easy.

For exFAT you might need apt-get install exfat-fuse exfat-utils before you can mount it.

Source: http://ubuntuforums.org/showthread.php?t=2270831

  • Thank you! fixed it and it's working. There are a host of other things that aren't working based on the link you sent but having access to wifi makes it possible to search for answers. I also forgot I had a usb 2.0 to ethernet adapter. Commented May 19, 2015 at 21:29
  • @Gawin does the same work for any version of ubuntu ie can I use the blob from the kernel repo always and how should I update it ?? Commented May 29, 2015 at 22:10
  • No, this works with kernel 3.19 and above. See this wiki about the chipset: link Commented Jul 29, 2015 at 22:42
  • 1
    I see that it works for elementaryOS loki as well on rMBP early 2015 Commented Sep 17, 2016 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .