1

I just installed Ubuntu on a HDD and when I restart my computer, it goes straight to Windows 8 login. I have 256GB SSD (where my Win8 and other important programs are installed), and another 2TB HDD. I have the HDD split into two 1TB partitions. The first 1TB I save all my non essential software and the second is empty. So I want to install Ubuntu on my second 1TB partition.

These are the steps I followed -

  1. Right clicked on my Other E: drive and clicked shrink and making a new partition for 100GB for my linux to be stored.
  2. Then I restarted my computer with Ubuntu CD and clicked Install Ubuntu
  3. Clicked continue until I reached where I want to install Ubuntu.
  4. I clicked Something else
  5. Clicked on free space -> then +
  6. Size i put 2048MB for Use as I put Swap area then I clicked ok.
  7. Then I made a root partition by clicking on the rest of free space
  8. The size I chose whatever is left in the free space. For mount point I chose the root /
  9. For the boot loader installation drop down I chose /dev/sdb ATA ST2000DM001-1CH1 (2.0 TB) (My Windows 8 loader is on /dev/sda1. Do I have to choose sda for my ubuntu boot loader installation as well?)

I continued with the installation, it asked me to remove my CD from drive and restart. I did so, but it always goes straight to Win8 and doesn't ask me what I'd like to boot!

Just for reference, my fast startup is turned off.

Does anyone know why I might be having this issue and how to solve it? I've tried a lot of different things...How do you even delete the linux I just installed that I can't access? Can I go to Disk Management and Delete that partition as a whole?

Thank you for all the help.

  • Sounds like you might have an issue with Grub. Do you remember getting any kind of error suggesting that grub, or the boot loader didn't install correctly? – Brian Sizemore May 13 '15 at 1:30
  • No I never got any messages regarding Grub. I noticed that I chose sdb for my boot loader installation and my win8 loader is on sda. Could that be the issue? – user2921302 May 13 '15 at 1:32
  • 1
    I think that your secondary hard drive is just set to boot after the primary (Win 8) one. Fix this in your BIOS settings, by putting the secondary hard drive above the first in the boot priority. – TheWanderer May 13 '15 at 2:00
1

Found the problem!!

Out of the total 100GB partition I made, I used 2GB swap area and made another root partition for the rest of the space for Ext4. My problem was, at the drop down, to install the linux loader, I kept checking the sdb which is my HDD. But my windows 8 loader was on my sda.

Even though you want to put linux on a different hard drive than your other operating system, your loader has to be the same location as your original OS. In this case, my Win8 loader was in /dev/sda so I have to put my linux loader in sda. This has to be the same.

Sorry for the troubles, but thank you for the help!

|improve this answer|||||
0

You need to install a bootloader like GRUB. For now, try to go into your BIOS settings (F12 usually does this) and choose the default boot disk.

|improve this answer|||||
  • I figured out the issue and posted as an answer, thank you for your help though :) – user2921302 May 13 '15 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.