After a new install on my newly-built HTPC, I can't boot! I end up in initramfs every time, and get lots of ata2: COMRESET failed (errno=16)

Full error here:

ata2.00 exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: cmd a0/01:00:00:60:00/00:00:00:00:00/a0 tag 0 dma 96 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2.00: status: { DRDY }
ata2.00: COMRESET failed (errno=16)

The machine:

  • Board: ASUS AT3IONT-I Duluxe
  • 2Gigs of OCZ Ram
  • 80GB Western Digital Laptop Harddrive
  • Ubuntu 11.04 Minimal

More details:

  • I've done multiple re-installs
  • I've done a disk check
  • I've done a CPU check
  • I've done a memory check
  • I've filled the first and last million bytes with zeros using Ultimate Boot CD
  • Checked SATA ports are enabled
  • Tried RAID, SATA, and AHCI modes
  • Tried all new sata cables.
  • Tried booting Arch from a USB - similar error: [sda] No caching mode page present and Error: boot device didn't show up after 30 seconds, then chucked into initramfs.


  • - Checked SATA ports are enabled - Tried RAID, SATA, and AHCI modes Sep 20, 2011 at 19:24
  • Tried all new sata cables. By the way, the disk spins down before that error occurs, is it possible it's the CDROM drive? Sep 20, 2011 at 19:41
  • attempt #3: bugzilla.redhat.com/show_bug.cgi?id=549981#c12 add the option line to grub to disable ncq : libata.force=noncq
    – Rinzwind
    Sep 20, 2011 at 20:51

1 Answer 1


I had this problem just now. Apparently it looks like a problem with a hard disk partition. I solved it like this:

  • When you get initram, type exit.
  • It gives you an menu with options. Select fsck.
  • Let it scan the hard drive. When its done hit the return key and it will immediately take you to login screen.

I noticed that the /home was not mounted when I checked in the initramfs. This should be because of your hard drive. Everything was fine when I did a normal shutdown of my system a month ago. This just happend when I started it today.

Anyways my system is up now. :-)

  • 1
    Glad to know that it was useful.
    – preetam
    Apr 15, 2014 at 3:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.