2

I installed OpenStack using openstack-installer's autopilot option.

After starting an instance, if I want to resize it (i.e. change its flavor), this produces an error, the same if I try it with the instance turned on or off. The error log says something like this:

Failed to launch instance "datanode02": Please try again later [Error: Unexpected error while running command. Command: ssh 10.222.221.57 mkdir -p /var/lib/nova/instances/07e5308c-00c9-4314-92f5-fdb26a5a7f98 Exit code: 255 Stdout: u'' Stderr: u'Host key verification failed.\r\n'].

Clearly it's a key problem. The weird thing is that I'm able to create, turn on, turn off (all from Openstack Dashboard), log into those servers (directly with the key), etc, but I can't resize the instance, nor log into the console through Openstack Dashboard (probably due the same error).

My question is: Where I have to solve that problem? At the MAAS server? At Landscape's? At Landscape's bootstrap's? Where?

1
  • I see the same error. Trying to figure out if ssh keys are supposed to have been setup already by the services or charms, or if it's a manual step. – Andreas Hasenack May 13 '15 at 13:01
1

To manage/administer your openstack environment, you will need to use Juju to get access. You can see the steps here:

Once you do that, you will need to debug this service like any other. Landscape and Maas at this point are just guiding the installation. Certainly if you identify what is going on here, it would be great to feed that back into the installation process, so a bug might be in order, but there is nothing in the way of automated troubleshooting to point you at.

There are a lot of openstack resources out there, and this site may be better for this kind of question:

1

After you get access to the inner cloud environment (see https://askubuntu.com/a/598035/7056), you have to enable these settings in the nova-compute service (one command line):

juju set nova-compute enable-live-migration=True enable-resize=True migration-auth-type=ssh

Then watch juju debug-log until it quiets down, and your nova resize command should work:

andreas@nsn7:~$ nova resize --poll d8c264e1-9a19-4f49-a68a-f51717e7f2f7 m1.medium
Server resizing... 100% complete
Finished
andreas@nsn7:~$ 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.