I added the entry sftp://daniel@<somedomain> to my bookmarks in Nautilus. The first time it was accessed it asked for the password but never after that. I cannot remember which option I selected to remember (e.g. until end of session).

In any case, I want Nautilus to forget the access password and ask me every time I open the remote file system. Unmounting did not cause it to forget the password. I've also opened seahorse and this key is not there.

Any idea where the key is stored and how can I force nautilus to forget the password?

  • 2
    "Try deleting the bookmark. Then create it again." -- This didn't work.
    – Daniel
    May 13, 2015 at 15:02
  • 1
    "Did you check for ssh password in seahorse?" -- There is only one entry there and it is for something else. Since the password is supposed to be remember until the end of the session, perhaps it is stored in memory but that's just guessing.
    – Daniel
    May 13, 2015 at 17:11
  • Sorry, I am out of ideas.
    – user68186
    May 13, 2015 at 17:38

4 Answers 4


I did the same thing as you and was also surprised not to find the key in seahorse. The only way I found to make Nautilus forget the pwd was to close my session. Then nautilus asked me the password again, with the same 3 options, and I selected the 1st one.

  1. Forget the password
  2. Remember until end of session
  3. Remember forever

I think it only stores the password in seahorse when you select the 3rd option. For the 2nd option, it must store it in a temporary place that I don't know about. For the 1st option, it doesn't store it at all.

  • 1
    With option 2 I found that restarting nautilus or gnome didn't work, but rebooting did
    – Andy
    Apr 15, 2021 at 7:40

On Ubuntu 16.04, this solved the issue:

  1. Click "Search your computer" (top left corner)
  2. Type Passwords and Keys
  3. Under Passwords - Login, you can right click and delete the saved password

Reference: jamesisin's answer in this post

Hope that helps!

  • As stated in another answer, this only works if you have selected "remember forever" (the "passwords and keys" app is seahorse).
    – Andy
    Apr 15, 2021 at 7:35

On Ubuntu 18.04, this solved the issue:

  1. Click on the apps icon (bottom left corner)
  2. Search on search-bar Passwords and Keys
  3. Click on it
  4. Right-click on the key you wish to remove under Login tab and press Delete

Source: https://askubuntu.com/a/1043437/1171332


run seahorse from the bash:
https://ask.fedoraproject.org/en/question/23350/where-to-find-nautilus-password-storage-for-shares/?answer=23351#post-id-23351 //for 30 character answer...

  • 1
    Welcome to AskUbuntu! Answer that a purely link based are of low quality. Please provide more details.
    – user308164
    Aug 6, 2016 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.