2

I configured linux guest in kvm runing on ubuntu14.04 host. It runs without any problem and has no issues with DNS.

After connecting host to VPN (OpenVPN), guest is not resolving anything from DNS anymore... Host has no issues... Same problem from host when I use vm's automatically created DNS to resolve any domain name:

host:/$ nslookup google.com 192.168.121.1
guest:/$ nslookup google.com 192.168.121.1
guest:/$ nslookup google.com
  • before host's OpenVPN connection all commands resolve google's IP list...
  • after OpenVPN connection all commands output is "** server can't find google.com: SERVFAIL"

    host:/$ nslookup google.com

  • this resolves list of google's IP before and after OpenVPN connection

host's /etc/resolv.conf before OpenVPN connection

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.1
search XXXXXXXXXXXXXXXXXX

host's /etc/resolv.conf after OpenVPN connection:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.200.1
nameserver 192.168.1.1
search XXXXXXXXXXXXXXXXXX, YYYYYYYYYYYYYYYY

guest's /etc/resolv.conf before and after host's OpenVPN connection is the same:

options single-request-reopen
; generated by /sbin/dhclient-script
nameserver 192.168.121.1

What could be a problem? Any ideas? I'm qute sure it was working few weeks ago... Do you think it can be related to some ubuntu upgrade?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.