1

I have successfully installed Ubuntu on a different partition than my Windows 8. When my machine boots, it loads Ubuntu automatically so I searched and found that I can use boot-repair to fix that.

I ran boot-repair and used the (automatic repair) ... After a several minutes boot-repair returned the following:

The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode.

When I restart my machine and change the boot mode to be UEFI instead of legacy, Windows 8 loads automatically and I can't start Ubuntu ...

Does this mean that I should switch between the 2 boot modes from the BIOS depending on the OS I want to start?

This is the analysis that boot-repair made: http://paste.ubuntu.com/11082141/

Update:

Tried installing and updating GRUB but nothing happened

The model of the laptop is Lenovo 50-70. Secure boot is disabled but UEFI is enabled. I have option to boot from USB but it doesn't show up on the priority list. Only HDD and network are being displayed.

Update 2

Here are screenshots from my BIOS

enter image description here

enter image description here

Update 3

These are the boot options I get in the UEFI mode:

enter image description here

Update 4

I was able to boot from the USB back again but in legacy mode, not the UFEI mode. Is there another way to make me able to use dual boot without having to enter the BIOS setup to switch between the two Operating Systems?

  • Have you already tried to install/reinstall/update GRUB? – Eduardo Cola May 11 '15 at 17:31
  • @EduardoCola I started with boot-repair directly ... Will check GRUB and update – Ahmad Alfy May 11 '15 at 17:39
  • try sudo apt-get install --reinstall grub and sudo update-grub. – Eduardo Cola May 11 '15 at 17:40
  • What brand model system? Some require you to change UEFI settings to allow flash drive as bootable device in UEFI mode. You may have to turn off secure boot, but keep UEFI boot as default. Depending on brand you may have other settings also, review UEFI settings. You should get two options to boot flash drive. One clearly UEFI and one just label/name of flash drive which is just BIOS/CSM boot. – oldfred May 11 '15 at 17:41
  • @oldfred Updated the answer, will check again the boot setup – Ahmad Alfy May 11 '15 at 17:49
1

dont try boot repair try to update grub once you log into ubuntu type this grub2 update it should fix your problem if that wont help you its most likely of stupid way windows comes preinstalled on laptops ourdays you will be able to fix it only by reinstalling windows and ubuntu, id say going over boot menu is not that big of problem

| improve this answer | |
0

Try looking at: http://download.lenovo.com/consumer/mobiles_pub/lenovo_g40_g50_z40_z50_ug_english.pdf ( page 34, above "Getting HElp )

change UEFI for legacy Support.

your manufacturer, does not tell which is Linux( distribution ) compatible your Hardware.

| improve this answer | |
  • I am already able to change the boot from UEFI to Legacy ... but it has no effect – Ahmad Alfy May 11 '15 at 18:29
0

Change UEFI to legacy, reboot press F8 or F11 or F12 depending on your model and get to boot menu, and boot from usb

| improve this answer | |
  • 1
    I was able to boot from the USB in the legacy mode ... But still boot-repair doesn't work. It gives the same error I posted earlier – Ahmad Alfy May 11 '15 at 18:59
  • I'm having the same exact problem @AhmadAlfy – anon58192932 Apr 14 '17 at 18:53
0

First, insert your Live USB into your computer. Then, boot into windows 8. then, go to the Settings charm --> Power Options --> press Restart while holding the shift key. In the menu that appears, click on "Use a device." Then, select your Live USB, BUT MAKE SURE TO CHOOSE THE ENTRY WITH "EFI:" IN FRONT. THIS IS WHAT WILL MAKE YOU AVOID THE ERROR. Then, choose "Try Ubuntu" from the Live USB's menu and install and use the boot-repair utility.

NOTE: Sometimes theoption to boot the live USB in EFI mode does not appear. If this is the case, remove the Live USB from the computer, boot back into windows 8, and follow these instructions from the beginning.

| improve this answer | |
0

OK,

so Try other distribuition linux? something other than Ubuntu?

as well as Open Suse: mote information: http://distrowatch.com/table.php?distribution=opensuse

or just:

Arch Linux http://distrowatch.com/table.php?distribution=arch ( very simple and biggest alternative for to customize )

or Fedora like-Red hat enterprise linux

Try,

one Distribution, I Said. starting can give, say if it will work or not.

The GUIDE says little about linux installations. let's try and see what the best option.

I see you later. bye.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.