14

I have recently upgraded to ubuntu 15.04. After this, I am facing some weird errors.

  1. My shortcut CTRL + ALT + T stopped working for terminal.
  2. Function keys for Sound not working anymore.
  3. My keyboard settings are not working, not able to switch or use any other language except english.
  4. Unity tweak tool throwing error on startup. Following Schema is missing: org.gnome.settings-daemon.peripherals.touchpad

What am I doing wrong and how should I remedy this?

  • does the shortcut start working if you run gnome-settings-daemon in terminal ? – Sergiy Kolodyazhnyy May 11 '15 at 20:06
  • No, I doesn't work. Even when I ran this command, my touchpad "Click" stopped working, but touchpad buttons and pointer were working successfully – Incredible May 12 '15 at 2:42
  • 1
    Are you experiencing this bug? bugs.launchpad.net/ubuntu-gnome/+bug/1427877 – MDCore May 15 '15 at 8:41
  • Yes! It is similar. But even if I restart gnome-settings-daemon, it doesn't work, neither on system restart. Also, it when I try to change keyboard and mouse settings from SYSTEM SETTINGS, it just close the settings window on click :( – Incredible May 16 '15 at 18:08
  • I had a similar problem and my solution was to remove guake, which was in conflict with the default terminal – JeffDror Jun 3 '15 at 11:17
9

Try to turn off or on shortCuts(Commands) in CompizConfig Setting Manager (Icon with keyboards keys y+z+Ctrl). This solved my problems with shortcuts in Unity Ubuntu 15.04.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Pilot6 Jun 17 '15 at 9:56
  • 1
    @Pilot6, you are wrong. This does, in fact, provide an answer to exactly the problem that the OP describes. I was encountering very similar keyboard behavior (Ctrl-Alt-T stopped working, etc), and found that doing as jeti_ suggested completely fixed the problem, without any need to uninstall/reinstall anything. I highly recommend people try this solution first. – Foogod Dec 5 '15 at 20:39
  • 1
    I just upgraded from 14.04 to 15.04 and my media keys had stopped working. Disabling the Commands CCSM plugin worked for me. Thank you. – dty Dec 21 '15 at 13:57
  • @foogod exactly what did you do? What does "Icon with keyboards keys y+z+Ctrl" mean? – yPhil May 6 '16 at 1:53
  • When you open the CompizConfig Settings Manager (/usr/bin/ccsm .. you may need to install the compizconfig-settings-manager package first), there will be an icon shown under the "General" section which says "Commands" next to it, and looks like part of a keyboard (with the "x", "y", and "ctrl" keys visible). Click on that icon and then in the region on the left side you'll see a checkbox for "Enable Commands". Uncheck and recheck that checkbox (it may take a second or two for it to update when you turn it off or on) – Foogod May 10 '16 at 2:02
3

After so much efforts I was able to solve my problem myself. I did the following steps and it worked.

  1. Uninstall gnome-settings-daemonsudo apt-get remove gnome-settings-daemon
  2. uninstall all other packages, which are not required sudo apt-get autoremove
  3. After uninstalling, I tried to install gnome-settings-daemon again using sudo apt-get install gnome-settings-daemon but it started showing me some broken dependencies issues related to gnome-settings-daemon-schemas.
  4. So, I opened Synaptic Package manager and reinstalled gnome-settings-daemon-schemas.
  5. After it, I installed gnome-Settings-Daemon from Synaptic package manager and it was successfully installed without any dependency issue.

restarted the system and Everything started working except Unity Tweak tool which was now giving me new error that com.canonical.unity.webapps is missing. So, I installed sudo apt-get install unity-webapps-serviceand it worked.

Now, the only problem I am facing is Indicators are missing. like TextEntry change indicator on taskbar, screen brightness change, sound change indicators etc. But everything is working now.

Thanks, I hope my answer will help

  • Worked for me also on Ubuntu 15.04. Thanks – ovrwngtvity Jan 17 '16 at 12:29
0

I also have the problem with the non working Audio function keys after upgrading to 15.04. I've reassigned them to some other custom keys via System Setttings > Keyboard > Shortcuts. I use Ctrl+Shift+arrow_keys now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.