12

I used to write and read .odf and .doc files in Arabic on my laptop and then suddenly one day LibreOffice stopped reading and writing in Arabic. I can normally write in Arabic in the browser for example or in other programs but if I for example copy and paste an Arabic text in LibreOffice it would only paste numbers and symbols. Same thing if I enable the Arabic keyboard and try to type in Arabic: no letters will appear in the document.

What is wrong?

(Sorry I am quite ignorant about these kind of issues (but willing to learn). Please try to speak a human language to let me understand which steps should I follow).

Thanks a lot

  • Did you try changing the keyboard layout for your session? wikihow.com/Change-Keyboard-Layout-in-Ubuntu – David Foerster May 11 '15 at 16:00
  • Yes I did. I normally write in Arabic using for example the browser and other programs ( as you can see here السلام عليكم). It's not about changing the keyboard layout. The only issue is with LibreOffice. – Francesco May 12 '15 at 6:13
  • alefba.us/libreoffice-arabic-persian Have you tried this? – Maud Kon May 21 '15 at 11:59
  • @Francesco , Could you add a showcase. Copy-paste this text to LibreOffice then post a screenshot of it. – user.dz May 29 '15 at 20:33
  • Sorry I don't now how to post the pic. (But I can tell you the only text pasted was numbers and Latin letters) – Francesco May 31 '15 at 8:57
1

I assume that you want to type from right to left ?! Right ?!

Well, there are two methods:

A) Complete new Ubuntu Installation into Arabian-Language with Arabian keyboard and Hardware purchased at airport in Dubai.

;o)

B) Here is the link to add new fonts for libreoffice (you simply need to add fonts in gimp):

How to add new fonts to gimp?

Happy coding and writing and a nice winter-time to you.

1

It looks like you have a corrupt preferences tree saved on your system.

backup this directory "/home/yourUserName/.config/libreoffice/VersionNumber/user", and remove it from there . This will revert your LibreOffice to fresh install status . Note: your custom settings,personal dictionnary, & recent docs list will be lost ! but youcan restore them one by one from your backup.

0

In System Settings > Region & Language > Input Sources add the Arabic keyboard layout you need.

While in Libre Office Writer, change your keyboard layout (in Gnome Shell it is at the top right corner of the screen), and start typing.

On my Ubuntu 14.04 it worked, but the list of available keyboard layout was not updated until I logged out & in from the system.

0

Go to the Ubuntu settings menu and then click text entry. Add your preferable language. This way you can type with your preferable language.

0

Did you enable support for "Complex Text Layout" (CTL)? See https://help.libreoffice.org/Common/Selecting_the_Document_Language

Although I haven't tried this I understand it allows you to type Arabic text Right to Left.

Go to Tools -> Options -> Language Settings -> Languages. Check the box at "Complex text layout (CTL)" - You can then specify the default language in the drop-down list (there are eight different versions of Arabic to choose from).

You can also specify that this will only apply to the current document fi you wish (check box on right).

If you want to have Arabic as the display language for the whole application, you can download an Arabic version of LibreOffice: http://www.libreoffice.org/download/libreoffice-fresh/?type=deb-x86_64&version=5.2&lang=ar

protected by Community Jan 6 '18 at 1:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.