0

I have a Dell in which there is a first drive running Windows 8.1 With UEFI, this works fine.

In order to install Ubuntu 14.04LTS I had to disable secure boot. A second drive is in the machine, a 256Gb SSD. I installed Ubuntu on the second drive but at the end of install, it says "failed to install grub on /dev/sda.

As mentioned in another question: "Unable to install GRUB in /dev/sda" when installing GRUB

I attempted to install grub to /dev/sdb but that fails too. Aside from removing the Windows drive entirely so that the SSD is /dev/sda, is there anything I can do?

Other questions talked about other settings on laptops, like "fast boot" but I don't see any options like that.

Aside from telling me how to solve the problem, does anyone have an explanation as to what is actually going on? Why should I not be able to write to the MBR of drive /dev/sdb, which is blank and on which I just installed linux?

4
  • I think your problem is that the Ubuntu installer isn't booting into EFI mode, and is instead using legacy mode. If you booted from it using the BIOS boot menu, that's why. Does your computer have an option to "Boot from EFI file" or something like that? – TheWanderer May 11 '15 at 14:33
  • Zacharee1 may well be correct. You can check your boot mode in the Ubuntu installer by dropping to a shell and looking for the /sys/firmware/efi directory. If it's present, you booted in EFI mode; if not, in BIOS mode. You might be able to get your installed system to boot by using rEFInd, either installed in Windows or run from a USB flash drive. You can then either use rEFInd as your boot manager or install the EFI version of GRUB in any of several ways. – Rod Smith May 11 '15 at 18:05
  • Sorry, I don't understand. I though the whole point is to disable UEFI and boot unsecure to get ubuntu to work. @RodSmith I will try – Dov May 12 '15 at 1:30
  • When dual-booting, it's almost always best to boot both OSes in the same mode (both in BIOS or both in EFI), not to mix modes (one in BIOS, one in EFI). Since you've already got a working Windows installation, you should attempt to match its boot mode when you install Linux. Pre-installed Windows 8 and later almost always boot in EFI mode. See my page on EFI-mode Linux installations for more information. – Rod Smith May 12 '15 at 12:15
-2

your pc not compatible with linux http://www.dell.com/br/empresa/p/optiplex-9020-desktop/pd

try other distribution, samble: OpenSuse

Suse compuny belongs the Microsoft, due to this great compatibility hardware exclusive windows Platform.

att

1
  • 2
    That computer is definitely compatible with Linux, as are all full home towers. Also, OpenSUSE is Linux, which puts a contradiction in your answer. – TheWanderer May 11 '15 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.