0

So far, I have used VGA and DVI monitors on NVidia GeForce 650 card and all worked flawlessly. Today I purchased BenQ 2460 HDMI monitor, connected it, NVidia Xserver Conf tool recognized it

but the screen remained black on HDMI monitor (BenQ 2460). When I turn it on it keeps saying "No Cable Detected".

I used the latest NVidia drivers

I have no idea how to solve this. Pressing "Detect monitors" does not help at all.

What shall I do? I thought that vga/dvi/hdmi is supported combination on Ubuntu 14.04.

I also read all top posts on similar issues and they did not help. Should I install some other drivers maybe?

XANDR output:

xrandr
Screen 0: minimum 8 x 8, current 5520 x 1080, maximum 16384 x 16384
VGA-0 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 459mm x 296mm
   1680x1050      59.9*+   60.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
DVI-D-0 connected 1920x1080+1680+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1280x800       59.8  
   1280x720       60.0  
   1024x768       60.0  
   1024x576       60.0  
   800x600        60.3  
   640x480        59.9  
HDMI-0 connected 1920x1080+3600+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080      60.0*+   59.9     50.0     60.1     60.0     50.0  
   1680x1050      60.0  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1280x800       59.8  
   1280x720       60.0     59.9     50.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   720x576        50.0     50.1  
   720x480        59.9     60.1  
   640x480        75.0     59.9     59.9  
VGA-1 disconnected (normal left inverted right x axis y axis)
  • Try using the legacy driver. People have had better luck with that. – TheWanderer May 11 '15 at 13:16
  • @Zacharee1 Legacy 304.125? And this 304 does not mean the driver is old (compared to 331)? – ubuntico May 11 '15 at 13:17
  • Well, it is older, but the newer versions, as with everything, tend to be less stable. 304, for it to be listed along with 331, must be more stable. – TheWanderer May 11 '15 at 13:18
  • @Zacharee1 Ok, I will try. Funny in another post I found a solution to use non-legacy one (the one I currently use) :) – ubuntico May 11 '15 at 13:20
  • NVIDIA seems to be extremely unstable on Ubuntu for some reason so, even if your card is only the next generation to the one that was fixed with the new version, there could be a huge difference. – TheWanderer May 11 '15 at 13:22
1

It looks like you're trying to use three monitors on one card which, as far as I know, isn't possible. Like you're experiencing, the third monitor will be recognized, but trying to enable it either won't work, or it will disable the non-main (secondary) monitor. It's not a driver problem or a problem with Ubuntu, it's just not possible.

  • Thanks. Just noticed that when I detach VGA, and leave only DVI/HDMI combination (2 monitors), HDMI one does not work again. Shall I ask a new question about this? – ubuntico May 11 '15 at 13:53
  • @ubuntico Yeah. Have you tried the legacy driver, though? – TheWanderer May 11 '15 at 14:05
  • YEs, I am on it :(. Anyway I think I will fetch another card and connect HDMI monitors to it since my old vga/dvi combination worked before – ubuntico May 11 '15 at 14:06
  • That'll definitely work – TheWanderer May 11 '15 at 14:06
1

It was not an issue with a graphics card. I checked and it supports 3 monitors at the same time. And Ubuntu DOES support this (14.04).

In my case, BenQ did not automatically recognize which cable was on so I had to manually set that input is coming from HDMI.

I now have image on all 3 monitors and all is working flawlessly.

  • Thank you kind sir. Indeed don't forget to loop up the source settings of your monitor (on my Samsung I have a button called "source"). – nakajuice Nov 18 '15 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.