1

Is there an easy way to install Lubuntu on an old T41 with a Celeron M?

What I tried:

  • Downloaded the 32 Bit version of Lubuntu
  • install Ubuntu 15.04 on my USB drive with unetbootin
  • additionally after finding this bug report, I run the following commands:

    cd /usr/lib/syslinux/modules/bios/
    cp libcom32.c32 /media/path/to/usb/drive/
    cp libutil.c32 /media/path/to/usb/drive/
    cp menu.c32 /media/path/to/usb/drive/
    

Now only this message is left:

WARNING: PAE disabled. use parameter 'forcepae' to enable at your own risk!
This Kernel requires the following features not present on the CPU:
pae

It seems I have to install fake-PAE on my USB drive as well somehow, but I only found solutions how to install that with apt-get in a running system

UPDATE:
I pressed tab in the Grub menu of the USB installer and added forcepae at the end of the showing commandline:

/ubnkern initrd=/ubninit forcepae

Then it started booting, but then after a while I get a BusyBox shell.

So this doesn't seem to be the whole solution.

How do I install Lubuntu on a T41?


I guess that would be a not desirable workaround:
install 12.04 and upgrade twice to the latest version.

  • Maybe, but if you don't narrow your question down to something that's actually answerable then it will get closed as "too broad"... You're now 1 step further and ready to tackle the next issue in another question. – Jan May 13 '15 at 7:12
2

Excursus: PAE on Banias CPUs

The T41 has a Pentium-M CPU, which came in "Dothan" and "Banias" flavors. Both are PAE capable, but the Banias CPU doesn't advertise this via the CPUID.

To work around this issue, a patch was included in the linux kernel from version 3.15 on. This patch recognizes the Banias CPU and, in conjunction with forcepae, enables PAE on these CPUs.

How to boot a PAE kernel on Pentium-M

At the boot menu screen the options are

1.Install  
2.Command-line options  
3.Advanced options  
4.Help  

With the cursor on the top choice press F6.
A menu with a number of options appears. The option forcepae is not there, so press Esc to close the list.
Now a string of options is visible, often with quiet or quiet splash -- at the end. Add forcepae to the string before and after the two dashes ("forcepae -- forcepae"). Press return, and the installation begins.

Depending on the version of the kernel you're using, you may see a warning about forcepae being experimental, you can ignore this on a Banias CPU.

The forcepae option must be entered twice, before and after the delimiter "-- ", so that it is applied to both the kernel on the ISO and the kernel on the system after installation. This is a change from older installs where only one parameter was sufficient. The change applies to Ubuntu Server 14.04.2, 15.04 and later (although it will do no harm to use it on early releases).

Technical note: After booting, dmesg | grep -i pae will now show PAE forced!. You can use this as a check.

From https://help.ubuntu.com/community/PAE

  • I don't have those 4 options, Unetbootin gives Default, ... "Try without installing", and some more. I selected the latter and had three dashes so I added forcepae before and after the three dashes with a space between and it works! Great, thanks. You want to add this to your answer? – rubo77 May 11 '15 at 9:38
  • Well, it's in the first comment so I guess it's OK to just keep it like that. Once installed, you could also install / compile a non-PAE kernel... – Jan May 11 '15 at 9:44
  • Why should I install / compile a non-PAE kernel? is it faster? more stable? My system seems to run fine as it is now. – rubo77 May 11 '15 at 23:12
  • Err... that was just a gut feeling along the lines of "Why have PAE in the kernel when the system doesn't support it?", but I'm not entirely sure if and how running a PAE-kernel in non-PAE mode differs from running a non-PAE kernel in the first place. – Jan May 12 '15 at 6:41
  • Seems your CPU is in fact PAE capable, so no need for a non-PAE kernel. Edited answer accordingly. – Jan May 12 '15 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.