0

This question already has an answer here:

I've setup an SSH server on my Ubuntu desktop at home using a dynamic DNS service (NOIP). I have a wi-fi-only Android tablet running Android version 4.4.2.

Port 22 is forwarded, ufw is disabled currently.

On my tablet I can connect to other SSH servers, such as my college's server. However, I cannot directly connect from my tablet to my desktop; every attempt times out. But I am able to connect to my college's server and then SSH into my desktop from there. I'm also able to SSH into my desktop when I'm at home and I use the desktop's network IP address. I'm able to ping the public IP and receive responses.

But I'm at a loss to explain this behavior. It seems odd that I have to connect through another SSH server. Has anyone experienced a similar issue? Thanks in advance!

edit: adding error

failed to connect to name/ip-address (port 22):  
connect failed:ETIMEDOUT(Connection timed out)

marked as duplicate by user68186, Eric Carvalho, Maythux, Registered User, Pabi May 12 '15 at 11:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Originally passwords, but I just changed it to keys only. Same result either way. "failed to connect to name/ip-address (port 22): connect failed:ETIMEDOUT(Connection timed out)" – rob May 11 '15 at 2:26
  • 1
    See askubuntu.com/questions/240514/… Also check your firewall setting in the router as well as in the Ubuntu desktop, if you have setup a firewall there. – user68186 May 11 '15 at 10:54
  • Thanks user, that was a good read. Got it figured out; my router doesn't support connecting to the WAN IP on my desktop while I'm behind it, as your link and solsTiCe both said – rob May 11 '15 at 13:41
  • You are welcome. My router behaves the same way. I have created two entries for my desktop ssh. One to use within the LAN using either the local name like mydesktop.local or 192.168.x.y or using the WAN name from the DDNS service provider. – user68186 May 11 '15 at 15:20
1

I think you can't access an IP of your LAN when using its global FQDN. You need to use its private IP adress.

  • So if I were to join another wifi network that doesn't include my desktop, I may be able to connect? I'll give that a try – rob May 11 '15 at 2:51
  • You're right, I was able to connect once I was off my local network. Thanks! – rob May 11 '15 at 13:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.