2

I have a Dell Inspiron 15 3000 series, with an Intel HD5500 graphics card, running Ubuntu 14.04. My problem is that the colors on the screen are all washed out. They also look too blue. I have tried adjusting gamma and contrast using xcalib, but all it does is make the problem worse. I have also tried using Gnome Color Manager, but the calibration button is grayed out. I've looked on the Intel website for different drivers, but they only list basic development drivers with no support.

I can use xgamma to increase or decrease the gamma, and this does help, but what I really need is to increase the contrast. Contrast, via xcalib, is already 100%. It seems, with xcalib, all I can do is lower values, when what I need to do is increase them. Can anyone help with this? Thanks.

8

Try running the following command from a terminal while logged in:

xrandr --output HDMI1 --set "Broadcast RGB" "Full"

Your screen will probably flicker/turn off momentarily to apply the new settings.

If that fixes your problem, you can add this command to your ~/.xprofile file so that it runs whenever you log in to the graphical environment:

echo 'xrandr --output HDMI1 --set "Broadcast RGB" "Full"' >> ~/.xprofile

Hope that helps! It took me months to discover this fix!

| improve this answer | |
  • Just to help here, mine was HDMI-1 rather that HDMI1. If you just do 'xrandr' it will tell you which monitors and modes each monitor is on. Interestingly my 2nd monitor was DP-1 as I'm using a USB-C hub, but this worked a charm! – Farkie Nov 14 '18 at 11:45
  • Woks on my Lenovo laptop when replacing HDMI with eDP-1 and in general the --output value is the value of: xrandr | grep " connected" | sed -e "s/([A-Z0-9]\+) connected.*/\1/" – David Soroko Jul 31 '19 at 19:08
  • I get the following error message: X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 11 (RRQueryOutputProperty) Serial number of failed request: 56 Current serial number in output stream: 56 – Alexej Magura Oct 29 '19 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.