6

I'm new to Linux and to this forum, I recently purchased a DELL XPS-13 with Ubuntu 14.04.

Until now suspending my computer, either by closing the lid or clicking "suspend" in the menu did suspend my computer. I even sometimes had some problem waking it up, with the screen remaining black when I opened the lid. Now this issue seems to be fixed, but whenever I close the lid or click suspend, my laptop's screen remains lit, and just shows the login page, which, as you can imagine, has an impact on battery life.

I don't know why, but I can't get the screen to turn off when I close the lid or suspend.

I tried to run in Terminal

pm-suspend

and

pm-hibernate

but none seems to work at all, nothing happens.

I tried running the solution mentionned in this post but nothing seems to work...

Any idea what might be the problem?

Thanks


Yes I wrote sudo before the command. Here are the results of both commands:

adri@Adri-XPS-13:~$ sudo pm-suspend   
[sudo] password for adri: 
adri@Adri-XPS-13:~$ uname -r
3.16.0-37-generic
adri@Adri-XPS-13:~$

closed as off-topic by WinEunuuchs2Unix, David Foerster, αғsнιη, Eric Carvalho, waltinator Nov 6 '16 at 15:29

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – David Foerster, αғsнιη
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What kernel do you use. Give output of "uname -r" – Pilot6 May 10 '15 at 14:58
  • The output is "3.13.0-52-generic" – lancelot May 10 '15 at 16:03
  • 2
    I'm voting to close this question as off-topic because the OP hasn't signed on in 18 months and problem has likely been resolved without the solution being posted. – WinEunuuchs2Unix Nov 5 '16 at 22:47
  • Possible Duplicate: askubuntu.com/questions/395428/… – Elder Geek Nov 6 '16 at 15:31
1

You can upgrade to kernel 3.16, which is default in Ubuntu 14.04.2 and see if this problem has been fixed. To do it, run the command:

sudo apt-get install linux-generic-lts-utopic

And reboot.

  • I did it, it didn't seem to change anythiing... – lancelot May 10 '15 at 16:21
  • Do you do it with sudo, like "sudo pm-suspend"? – Pilot6 May 10 '15 at 16:33
  • And give output of "uname -r" now – Pilot6 May 10 '15 at 16:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.