I have a ubuntu server 14 with working pptpd. But after it upgraded to 15 with do-release-upgrade, the pptpd is failed. I can start this service, but it won't accept any connection from client.

I dont know where the log of pptpd is. When i check service pptpd status, i got this:

May 10 02:45:56 segnetproxy pptpd[12134]: CTRL: Starting call (launching ppp...)
May 10 02:45:56 segnetproxy pptpd[12119]: /usr/sbin/pppd: Plugin /usr/lib/pp...6
May 10 02:52:44 segnetproxy pptpd[12217]: CTRL: Client a.client.ip.address control...d
May 10 02:52:44 segnetproxy pptpd[12217]: CTRL: Starting call (launching ppp...)
May 10 02:52:44 segnetproxy pptpd[12119]: /usr/sbin/pppd: Plugin /usr/lib/pp...6
May 10 02:52:44 segnetproxy pptpd[12217]: GRE: read(fd=6,buffer=7fee990de4a0...s
May 10 02:52:46 segnetproxy pptpd[12219]: CTRL: Client a.client.ip.address control...d
May 10 02:52:46 segnetproxy pptpd[12219]: CTRL: Starting call (launching ppp...)
May 10 02:52:46 segnetproxy pptpd[12119]: /usr/sbin/pppd: Plugin /usr/lib/pp...6
May 10 02:52:46 segnetproxy pptpd[12219]: GRE: read(fd=6,buffer=7f789f93f4a0...s

All lines related to GRE are red.

When I try to run pptpd in foreground, every connecting trying prints a line:

/usr/sbin/pppd: Plugin /usr/lib/pptpd/pptpd-logwtmp.so is for pppd version 2.4.5, this is 2.4.6

Any idea? Thanks.

  • after a system update, the error changed: May 11 23:53:36 segnetproxy systemd[1]: Started PoPToP Point to Point Tunnel.... May 11 23:53:36 segnetproxy systemd[1]: Starting PoPToP Point to Point Tunne.... May 11 23:53:36 segnetproxy pptpd[14681]: MGR: connections limit (100) reach...d May 11 23:53:36 segnetproxy systemd[1]: pptpd.service: main process exited, ...a May 11 23:53:36 segnetproxy systemd[1]: Unit pptpd.service entered failed state. May 11 23:53:36 segnetproxy systemd[1]: pptpd.service failed. – Allen St.Clair May 12 '15 at 6:55
up vote 2 down vote accepted

This wasn't a complete fix for me, but it got me past the error: "pptpd-logwtmp.so is for pppd version 2.4.5, this is 2.4.6"

If you edit the conf file:

sudo nano /etc/pptpd.conf

you can disable the logwtmp option by adding a # before it.

The issue appears to have been logged as a bug here:

https://bugs.launchpad.net/ubuntu/+source/pptpd/+bug/1451419

The suggestion to disable logwtmp came from a similar, but older bug:

https://bugs.launchpad.net/ubuntu/+source/pptpd/+bug/352622

Having got past that problem, the other part of the issue (at least in my case), was that GRE packets were not making it through my UFW firewall. That appears to be the problem for the author of this question as well. For some reason GRE was working fine under 14.10, but after I upgraded to 15.04, this stopped working. I found the solution in Dikei's answer to this question: Can't connect to PPTP VPN with ufw enabled on Ubuntu 14.04 with kernel 3.18

I added this rule to the file /etc/ufw/before.rules before the line # drop INVALID packets ...

-A ufw-before-input -p 47 -j ACCEPT

I had to stop and restart UFW (I did this via the GUI) before the change took effect.

  • Thanks. Though it's not fixed yet, but your workaround works perfectly. – Allen St.Clair Jun 28 '15 at 13:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.