2

I have a laptop with Intel HD graphics and running on Linux trusty 3.13.0-45-generic.

I never had problems connecting external displays to my Display Port, but now I got a new monitor and can not get my laptop to output the proper resolution.

The display is the Asus ROG Swift PG278Q.

When I run xrandr, all I get for the Display Port is

DP1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9 

Then I tried to add the proper mode manually, so I ran:

$ cvt 2560 1440 60
# 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync

Then added the mode:

xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
xrandr --addmode DP1 "2560x1440_60.00"

Upon activating the mode with

xrandr --output DP1 --mode 2560x1440_60.00

All I see on the display is the message

OUT OF RANGE

I also tried other resolutions and refresh rates with no success. On an other display my laptop manages 2560x1440p60 without problems. This particular monitor also works in this mode on a windows machine of mine.

Any suggestions on how to solve or debug this?

2

Alright, i figured it out myself.

Using the Monitor Asset Manager I could determine a functioning ModeLine for that Monitor, which is:

"2560x1440@60" 241,500 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.