0

I installed a USB-WLAN-Stick by using Windows Wireless Drivers-Application and windows drivers. It took me some time to get it run but now it works. The only problem I have got is, that it does not start automatically on ubuntu startup or the moment I log on with my account.

So I always have to manually add the following commands in the terminal:

sudo modprobe -rfv ath9k_htc
sudo modprobe -v ath9k_htc

After having done so, WLAN works perfectly. Is there a possibility to make WLAN start automatically on ubuntu startup?

Thank you for your ideas!

  • Could you post on a pastebin the output of dmsg|grep ath9k_htc ? So you need to reload the module every time. May be it did not load some firmware correctly or initialize correctly ? – solsTiCe May 9 '15 at 22:24
  • The Windows Wireless Drivers tool implies that you installed a driver with ndiswrapper. This should not be needed if there is a native driver such as ath9k_htc. If both are installed, they probably conflict. Please clarify. – chili555 May 9 '15 at 23:07
  • Thank you solsTiCe and chili5555 for your quick answer. First off all there is the pastebin link: paste.ubuntu.com/11059680 – BornToFlyBert May 10 '15 at 10:28
  • For explanation I run a Ubuntu 15.04 server and I used to run Ubuntu 14.04. In both cases I had problems with a stable WLAN-Connection. I know that there is a native driver included for my WLAN-USB-Stick, but it does not work properly. So I had to install the Windows drivers with the NDIS-Wrapper tool. I wish that you can help me to start WLAN on Ubuntu Startup automatically, because the WLAN-Connection is very stable and works very well. – BornToFlyBert May 10 '15 at 10:35
0

Your pastebin implies, because of the timestamp, that the driver doesn't load on boot. It may be blacklisted as a part of the process to install ndiswrapper. Check:

gksudo gedit /etc/modprobe.d/blacklist.conf 

Use nano or kate or leafpad if you don't have the text editor gedit. Is the line blacklist ath9k_htc listed? If so, remove it. Proofread carefully, save and close the text editor.

Next, please try, in a terminal:

sudo -i
echo ath9k_htc  >>  /etc/modules
exit

Reboot. Any improvement?

You may be able to improve stability by checking the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

If these changes are ineffective, you might try a driver parameter:

sudo -i
echo "options ath9k_htc nohwcrypt=1"  >  /etc/modprobe.d/ath9k_htc.conf
modprobe -r ath9k_htc
modprobe ath9k_htc
exit
  • No; it already loads automatically. OP needs to unload and then reload the module – solsTiCe May 9 '15 at 22:25
  • @solsTiCe I disagree. Please see the timestamp in pastebin. – chili555 May 10 '15 at 13:53
  • Thank you very much for helping me. First of all I want to say that this was a great help for me! @chili555 your solution works perfectly! I followed the steps you gave me above and without any error it figured out that it is the perfect solution. Once again it works. I am very happy :) Unfortunately B E F O R E I followed chili555s commands I found out, that the WLAN - Connection is breaking again, once in a time, which makes me feel unhappy again :( One problem solved another problem has returned. What can I do so far? Greentings – BornToFlyBert May 10 '15 at 18:41
  • In addition I want to say that WLAN Connection stability was much worse before at the moment it is working properly and I can live with that, unless it does not get worse. – BornToFlyBert May 10 '15 at 18:58
  • Please see my edit above. – chili555 May 10 '15 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.