0

So today I ran our computer through the built in package updating system in Ubuntu 14.04 to do some updates that we have put off for a while (Did this to try and fix the "hanging on reboot" issue). Unfortunately, now we can't login through the main login GUI. Whenever I type in the proper login info, the screen just goes black for a second then goes back to the login page. I have tried recursively changing the file permissions of my home directory, and have also tried removing .Xauthority, neither of which have solved said issue. I'd greatly appreciate it if someone could give me some clues as to where I should be looking next to fix this issue. I can provide any log file information that you feel would be helpful, no problem. Thanks for your time.

EDIT: Forgot to mention that I also cannot login through Guest Session, it does the same loop thing. I can login through the command line, however.

EDIT 2: So now I'm trying to access the computer from home using x11vnc. When I run that, I get the error "Invalid MIT-MAGIC-COOKIE-1 key09/05/2015 14:07:24 XOpenDisplay(":0") failed." I'm not sure if that's a symptom of the root problem, or if thats because I was unable to login via gui last night.

  • when you log-in through terminal can't you press Alt+F7 to get GUI? – Ron May 9 '15 at 11:37
  • The issue isn't that I can't get to the GUI login, its that I can't login through said GUI. When I login into the F1 terminal then hop back, I get the login GUI page. – Jon Ellis May 9 '15 at 19:09
1

Press Ctrl+Alt+F3 and login into the shell.

Now run

 ls -lah. 

If in the output the line

-rw------- 1 root root 53 Nov 29 10:19 .Xauthority then you need to do chown username:username .Xauthority and try logging in.

Else, do

 ls -ld /tmp. 

Check for the first 10 letters in the left: they should read exactly so: drwxrwxrwt.

drwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp Else, you need to do

 sudo chmod a+wt /tmp 

and check again.If not both, I'd recommend you either

dpkg-reconfigure lightdm

or uninstall, reinstall it. Now press

 Alt+->

until you reach the login screen again, and restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.