1

I am unable to remove Plexmedia server from Ubuntu 14.04 Desktop 64-bit. Whenever I try to remove it via apt-get or dpkg -r, I am getting following error message.

happy@happy-desktop:~$ sudo dpkg --purge plexmediaserver
    (Reading database ... 191869 files and directories currently installed.)
    Removing plexmediaserver (0.9.11.7.803-87d0708-debian) ...
    update-rc.d: /etc/init.d/plexmediaserver exists during rc.d purge (use -f to force)
    dpkg: error processing package plexmediaserver (--purge):
     subprocess installed pre-removal script returned error exit status 1
    Errors were encountered while processing:
     plexmediaserver

I have tried searching on google, but could not find a solution.

Thanks for your time and please let me know if any more information is required from my side!

1

Try this command:

sudo dpkg --force-all --force-remove-reinstreq -P plexmediaserver

If that does not work, remove the files by hand:

sudo mv /etc/init.d/plexmediaserver /tmp

and again:

sudo dpkg --force-all --force-remove-reinstreq -P plexmediaserver
  • Thanks, moving the plexmediaserver from init.d manually and then executing the dpkg worked. – Simranjeet Sawhney May 10 '15 at 10:01
  • Sorry, can't upvote answers at the moment, so marking it. Thanks for the solution :) – Simranjeet Sawhney May 11 '15 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.