2

Does anyone know how exactly to get the driver installed for this and give a step by step guide? Everything I've tried so far goes to a dead end.

4

The device only works with ndiswrapper. With a temporary working interet connection by ethernet or any other means, open a terminal and do:

sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9

Download the driver file to your desktop here: http://downloads.linksys.com/downloads/driver/AE2500xp_WHQL,0.zip Right-click it and select 'Extract Here.'

Find out if you need the 32- or 64-bit files:

arch

64-bit returns x86_64. If yours is a 64-bit system, you will need to make an edit to the driver file. Open "bcmwlhigh5.inf" in gedit or any text editor and add this line, around line 170:

[Linksys_AE2500.files.NTamd64]
  AE2500xp64.sys,,,6

Proofread carefully, save and close the text editor. Now do:

cd ~/Desktop/xp
sudo ndiswrapper -i bcmwlhigh5.inf
sudo ndiswrapper -ma
sudo depmod -a

Reboot. If the wireless is not working, see if you can see any problems:

ndiswrapper -l

That's a lower-case L for 'list,' not the number 1. Also:

dmesg | grep ndis
  • It didn't work. The sudo depmod command was supposed to return something in the terminal, right? Every thing else did before it except that. – BigHippo May 9 '15 at 9:49
  • When I tried it again, it said it couldn't find section "Linksys_AE1200.files.NTamd64" even though that's not the adapter I'm using. Then when I tried it again, it said the driver was already installed. And the last command still doesn't return anything if it's supposed to. – BigHippo May 9 '15 at 9:55
  • And also, do you edit line 170 that has the 32 bit for AE2500 or do you add that whole to the document. I did the latter. I noticed that it has the 32 bit part for it twice. Was that so it might be edited for 64 bit? – BigHippo May 9 '15 at 10:15
  • One thing I did differently from this was that I already had a ndiswrapper 1.59 folder installed and extracted and the terminal gives an error on the bcmwlhigh5.inf command unless I moved that folder to the desktop. Should I just delete everything and try again? It's not like having these folder saved is doing much good right now anyway. – BigHippo May 9 '15 at 10:40
  • Is yours a 32- or 64-bit system? If 32-bit, you need do no edits at all. – chili555 May 9 '15 at 12:27
-1
sudo apt-get purge bcmwl-kernel-source

then run

sudo apt-get install firmware-b43-installer b43-fwcutter

Remove from blacklist if found.

check the file /etc/modprobe.d/blacklist.conf

if it contains an entry for bcm4* then put # to comment it or remove the whole line.

also notice if there is a file called bcm4* under the directory /etc/modprobe.d/ then remove it.

Now run the command:

sudo modprobe -r b43
sudo modprobe b43    
sudo rfkill unblock all
  • 1
    This method is incorrect. The b43 and ssb driver suite do not drive any USB device. – chili555 May 8 '15 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.