7

I've been googling many answers to this question, such as the various suggestions up and down https://askubuntu.com/a/202020/99436, and none of them are working for me. They might work for you. They don't work for me. The system blinks, icons on the launcher appear and dissapear, and I have to log in again - after that, it's still borked, just like before. I'm up to date as per

sudo apt-get update && sudo apt-get dist-upgrade 

Unity Tweak Tool is basically not functional. As I change settings, maybe 1 in 5 of them actually do anything. Clicking reset on individual pages doesn't reset anything (nothing actually changes on the screen, or in the system).

I've lost all the icons on the bar across the top of the screen - no network, sound, clock, username, the little cog. There's nothing up there. it's just grey. No amount of unity tweak resets brings them back for my user. They are all there and working on the logon screen. But for my user? Nothing.

Can I reset everything to how it was before I installed the horrible system trashing unity tweak tool? it's really frustrating that all the previous "reset" tools have been slowly removed, or that to reset one app I have to install and run some other app.

12

I had the same problem. This question is rather old, but still, here is the solution that worked for me:

To reset the the configuration run this:

dconf reset -f /org/compiz/

Than, to reset unity run:

setsid unity

Source:

http://ubuntuhandbook.org/index.php/2014/04/reset-unity-and-compiz-settings-in-ubuntu-14-04/

If you are wondering as I was, this is what setsid is doing: http://linux.die.net/man/2/setsid

  • After asking this and getting nowhere for ages, I ended up just making a new user and porting over to it. And then a couple of weeks back the hard drive starting the mystic whirr-click of death. So a full reinstall also works :) Thanks for the interesting info on setsid. – frumbert Jul 8 '15 at 14:03
5

Try a full reinstall, open terminal and run these commands one at a time

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
  • This one worked for my 15.10 system (After all these commands I had to run "unity" command in a terminal). – Gediminas Jeremiah Gudelis Apr 6 '16 at 1:38
3

None of the above answers worked.

I managed to truly hose my Unity configuration with unity-tweak-tool, and all it does is change values in the user's dconf config.

Just do the following, no sudo or apt or dumbledorfing required:

$ rm ~/.conf/dconf/user
$ unity
2

You can reset Unity, wiping all changes to configuration using Unity Tweak Tool.

sudo apt-get install unity-tweak-tool
unity-tweak-tool --reset-unity
0

To reset unity in a terminal type: unity --reset

  • 1
    it was depreciated in around 12.04. Doing this in 15.04 tells you that it's depreciated and does nothing. – frumbert May 8 '15 at 13:41
0

This works for me for ubuntu vivid (15.04):

killall unity-panel-service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.