6

I installed the proprietary AMD/ATI drivers on Ubuntu 15.04 64-bit, and restarted my PC. Now, it will show the Ubuntu logo, but won't go to the login screen. I can't switch to a terminal via CTRL+ALT+F1, CTRL+ALT+F2, etc.

I'm unsure how to uninstall the fglrx drivers if I can't boot to the login screen or terminal.

Running Ubuntu GNOME 15.04 64-bit w/ GNOME 3.14 on Acer Aspire laptop (model 8943G-9319, ATI Mobility Radeon HD5850)

Thanks in advance!

4
  • Can you explain how you installed the driver ? Can you use recovery mode ? wiki.ubuntu.com/RecoveryMode
    – Mark Kirby
    Commented May 8, 2015 at 6:21
  • Sure thing. I went to "Software & Updates", then to "Drivers" or "Additional Drivers" something like that, then I selected the radial option for fglrx proprietary driver (not fglrx-updates), clicked apply, let the program download & install the driver, then rebooted. It gets past the Ubuntu GNOME 15.04 logo, then goes to a black screen and freezes there. How would Iget into recovery mode?From GRUB?
    – Rebel
    Commented May 8, 2015 at 7:16
  • The link above shows how to get to recovery mode from grub, follow it and remove the driver by the same method you used to install it, reboot and tell me if it works again without the driver and we will try an alternative install once you can get into your PC
    – Mark Kirby
    Commented May 8, 2015 at 7:21
  • The uninstall part is covered here askubuntu.com/questions/68306/…
    – Bogdan
    Commented Aug 18, 2015 at 3:42

3 Answers 3

10

Thanks to the community, I found - and am writing down - the steps to remove fglrx AMD/ATI drivers when you can't get to the login screen (or a terminal/console/command prompt/etc.)

  1. Switch on your computer. Wait until the BIOS has finished loading, or has almost finished. (During this time you will probably see a logo of your computer manufacturer.) Quickly press and hold the Shift key, which will bring up the GNU GRUB menu. (If you see the Ubuntu logo, you've missed the point where you can enter the GRUB menu.)

  2. Select the line which starts with "Advanced options".

  3. Select the line ending with "(recovery mode)", probably the second line, something like: "Ubuntu GNU/Linux, with Linux 3.8.0-26-generic (recovery mode)"

  4. Press Return and your machine will begin the boot process.

  5. After a few moments, your workstation should display a menu with a number of options. One of the options (you may need to scroll down to the bottom of the list) will be "Drop to root shell prompt". Press Return with this option highlighted.

  6. The root partition is mounted read-only. To mount it read/write, enter the command:

    mount -o remount,rw /
    
  7. If you have /home, /boot, /tmp, or any other mount point on a separate partition, you can mount them with the command (unsure if this step is needed, but unless I'm corrected by someone, I recommend you type in this command as well, otherwise you may not be able to uninstall fglrx. And, again, the command:

    mount --all
    
  8. Type in the following command:

    sudo apt-get remove fglrx-*
    

    Enter Y to accept the changes. Ubuntu should then uninstall all fglrx drivers.

  9. Remove the X.org configuratiuon:

    sudo rm /etc/X11/xorg.conf
    
  10. Type in the following command to reboot your PC:

    sudo reboot
    

Ubuntu should now reboot and use the default open-source drivers again. Cheers!

4
  • if your partition does not mount as part of steps 5 and 6 - type in exit, in the menu choose enable networking - this will mount the file system now back to step 5. Commented Jun 14, 2015 at 20:34
  • 1
    You don't need sudo in root shell. You alreday are root.
    – ruuter
    Commented Sep 14, 2015 at 20:05
  • @ruuter, good point. Old habits. :)
    – Rebel
    Commented Sep 22, 2015 at 22:54
  • @TravLR I can relate.
    – retrixe
    Commented Nov 1, 2015 at 11:45
0

I had a similar issue, but thought I would just share how I fixed this issue.

I initially installed the driver with this command

sudo apt-get install fglrx

I then had the same issue as in the original post, except, I could actually switch the to the command line interface.

I then ran:

sudo apt-get remove fglrx

Which I assumed would fix the issue. I could then login, but I could not set my resolution at all, which is how I ended up on this post.

Running

sudo apt-get remove fglrx-*

as the initial answer seemed to work, and all is working now. No idea why the one does work and the one doesn't, but at least it's all fixed now.

-2

Have you tried this:

sudo apt-get install nvidia-update

and then this

sudo apt-get install nvidia:i386

and you can enter this

sudo apt-get install fglrx-*

startx

and use settings-detail and then check for update, and then enter updates and hatch the updated gfx driver and then this enter in the terminal:

 sudo apt-get update
 sudo apt-get upgrade
 sudo apt-get dist-upgrade

and it might work fine this way.

1
  • 2
    Michael, appreciate the reply, but the issue is about ATI/AMD graphics. Nvidia wouldn't really have any relevance, here. :)
    – Rebel
    Commented Aug 31, 2015 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .