2

I'm experiencing a similar problem to this thread in my personal machine (pentium 4 3GHz, 2GB ram, GeForce 6200 using nvidia-304).

After the update to Kubuntu 15.04, the desktop showed nothing but a black background with the mouse pointer, no response to ctr+alt+supr, but it was possible to login in another terminal with ctrl+alt+F1. And there end the similarities with the aforementioned link, because even after reboot the frozen desktop remained.

After retrying the install without the nvidia proprietary driver, the desktop showed, and it was usable after disabling compositing (Nouveau has the 'virtue' to corrupt many widgets in my machine). Leaving the compositing disabled allowed me to install the nvidia-304 and get into the desktop without hassle.

But here begins my problem: the performance of my graphics are quite poor compared to what I was accustomed in 14.14 and even some OpenGL aplications like glmark2 show error messages like

Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!

Applies that glmark runs with Nouveau without error messages, but it does with a disappointing performance.

I'm suspecting of a kwin issue, but I can't seem to find nothing of relevance beyond pre-release issues.

Anyone knows of a definitive solution besides returning to 14.10?

Thanks for your help

EDIT: This is not a driver install issue at all, because the driver is the one suggested by kubuntu and the last one supported by Nvidia.

Given that my card is just a old AGP card (a GeForce 6200 as mentioned above) it is unsupported by the newest drivers, and because the card worked fine with the same driver with all the previous kubuntu versions until 14.10, desktop compositing included, I still expecting the same behaviour for this release with the same driver version.

The only things that I think could break the setup are wayland or a buggy kwin, because of the locked desktop screen after the update (driver 304 running with compositing enabled in 14.10)

  • Why use 304 ? It is depreciated at least try with latest driver first then post back - sudo apt-get install nvidia-331 - maybe it is fully unsupported on 15.04? – Mark Kirby May 8 '15 at 5:55
  • possible duplicate of How do I install the Nvidia drivers? – Fabby May 8 '15 at 22:18
  • 304 is has the end of life driver support for the GeForce 6 series (is a AGP card), so is not a problem with the driver version, because the newer drivers don't support this card AND is the driver selected by kubuntu – Jorge Alzate May 10 '15 at 17:21
  • Compare the exact version of 304 with the exact version supplied by the xorg-edgers repository. I found for my Nvidia 6150 the xorg-edgers vers was one higher, and worked better. – ubfan1 May 10 '15 at 18:25
  • Thanks Ubfan1. I checked the version and it is the same to the one installed: 304.125, so is not a fix – Jorge Alzate May 12 '15 at 3:03
1

I think the problem is with the NVidia driver and the use of OpenGL. When you experience the black screen login on to an other tty and try the following: - sudo vi ~/.config/kwinrc - Change Backend=OpenGL to Backend=XRender - then restart with kill -9 -1

You should now be able to login using Plasma. It is however very slow but you can sometimes switch back to OpenGL. If you can switch you'll have the performace you expect from Kubuntu.

Before shutting down don't forget to switch back to XRender or you will have to repeat the same steps.

| improve this answer | |
  • Thanks Martijn. Your answer is the closest to a fix at this point. XRender allowed me to enable the compositing, however it is awfully slow (i.e. a simple window restore-resize consumes nearly 70% of my ageing CPU and takes near 3 seconds to finish). Nonetheless, the performance of the graphics card is still abyssal compared to the previous 14.10. I mark your tip as answer as it seems is the end of the road for my old machine. – Jorge Alzate May 19 '15 at 3:01
  • Hi Jorge. I got my machine working again (not quite as good as with 14.10) using the Nouveau drivers and setting the Compositor - Scale method to Crisp. I never had any good performance with the Nouveau drivers up until now. I hope it's the Scale method otherwise I made some changes that I don't remember anymore. I hope this helps. Good luck Martijn – Martijn May 25 '15 at 13:27
  • Hi Martijn. With Nouveau I experiment severe widget corruption with compositing enabled (the content from the most of the windows is replaced by the desktop background for example, and this is especially annoying when I boot ubuntu/kubuntu from a usb), also it doesn't work with wine games. In a single phrase, Nouveau is impractical for me. Maybe I'll give it a try in a couple of versions to see if something has improved – Jorge Alzate May 29 '15 at 3:58
0

I've got an Optimus nvidia Asus laptop. After install Kubuntu 15.04 (I did it in early state of Beta2) I wasn't able to make it work in any other way else than nouveau mode. This is what I did:

-Select nouveau driver in Drivers configuration

-Reboot

-In Terminal type: sudo remove nvidia* (to delete all files of my nvidia-340 propietary drivers)

-Reboot

-In my Account configuration I selected "auto login" and in SDDM advanced configuration I did it also (this is because the SDDM login screen crashes the startup of desktop with nvidia propietary drivers if it is not in optimus intel mode)

-In Terminal type: sudo install nvidia-346 nvidia-prime nvidia-settings

-Reboot

-After that I had my laptop working in nvidia-mode perfectly.

I also had an issue with "sudo dolphin" that crash my desktop and make the blank screen appeared with nothing else than the mouse pointer. To solve it:

-In the blank screen press Ctrl-Alt-F1 that leads to console

-Type sudo chown username:username ~/.cache/*

-Reboot

This is another known issue due to change the propietary user to sudo from your user when you use a gui application with the sudo command.

Hope it helps

| improve this answer | |
  • The same as my comment above: nvidia-364 does not support my card, because is a end of life product, and also because it worked fine in 14.10 (driver suggested and selected by the OS). I'll try your solution but with the 304 version – Jorge Alzate May 10 '15 at 17:25
  • UPDATE: stills the same. – Jorge Alzate May 10 '15 at 19:18
  • Removed nouveau from blacklist, Installed nouveau from driver config, updated initramfs, apt-get purge nvidia*, reboot, observed same nouveau behaviour, blacklist again nouveau, install again nvidia from driver config, update initramfs just in case, reboot and nothing changed. chown -R the .cache folder while the black desktop doesn't made a difference. I think my only option now is to get back to 14.10 and hope 15.10 gets better – Jorge Alzate May 10 '15 at 19:27
0

The nvidia-304 drivers will work with Kubuntu 15.04 if you disable the Compositor in System Settings->Display and Monitor

| improve this answer | |
  • If you read my post, that is my current setup. With compositing disabled I got hardware rendering for the apps, quite sluggish but hardware rendering – Jorge Alzate May 19 '15 at 2:55
0

You are probably hitting a kwin bug, I think. Kwin makes too optimistic assumptions on how sync should be performed and this does not work for older nvidia cards.

If this is the case, you can try the following:

Rather than disabling compositing, try creating a file kwin.sh in ~/.config/plasma-workspace/env/ with the following content

#!/bin/sh
export KWIN_EXPLICIT_SYNC=0

Then go to the system-settings -> Startup and Shutdown -> Autostart and Check/Add the script as a pre-kde startup file

See also https://bugs.kde.org/show_bug.cgi?id=348753

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.